Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Lulz

Disable/Change the "CreateSound"

Recommended Posts

So I am trying to change some of the unit sounds because i failed in completely disabling them.

the problem is: i already managed to find all those sound files with the XCC mixer but the names

of them are completely different as named in the Rulesmd.ini. 

So the question is: in which game file is the list which says which game sound to play equals which soundfile?

for instance: "BruteAttackCommand" is the soundfile "ibruatta"

Share this post


Link to post
Share on other sites

I think it's in sound.ini which is probably somewhere in langmd.mix

Share this post


Link to post
Share on other sites

If you're disabling them on a per map basis you can add the ini to the map from rulesmd.ini
 

[unitname]
CreateSound=

Leaving it just blank removes the sound.

Share this post


Link to post
Share on other sites

well.... as far as i know this is exactly what i did but it did not work!

i even tried: "none", "false" and  "0"

 

i can try it again... no not working. i can still hear tanya.

 

seems like it automatically uses the default value when there s no input...

 

i even tried disabling the original unit and creating a copy of the original unit in which the create sound was not implemented but the new unit didn t show up in the map albeit the original unit was disabled....

 

i guess i have to try it via the soundmd.ini:

 

MinVolume=90 and Volume=85

and putting both to 0...

 

also NOT working

Edited by Lulz

Share this post


Link to post
Share on other sites
21 hours ago, Lulz said:

i even tried: "none", "false" and  "0"

i can try it again... no not working. i can still hear tanya.

=Dummy

21 hours ago, Lulz said:

i even tried disabling the original unit and creating a copy of the original ... but the new unit didn t show up in the map

If you copy-pasted the code from original unit and original unit doesn't have `Image=` setting, you have to add string:
Image=`name of the original unit`

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...