Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Lord_Dweedle

Campaign ingame speed too slow.. not performance slow, just not as fast as

Recommended Posts

hmm. If I remember correctly there's a command line parameter for the game that unlocks this. I'm sure it's been mentioned on the forum somewhere...

 

[edit]

 

Found it:

Late reply I know, I rarely visit this forum :D

 

Just add -speedcontrol to your shortcut:

(In Windows 7, right-click your RA2 shortcut icon -> shortcut tab -> Target -> add -speedcontrol). It should be similar to other Windows versions.

 

Example: "C:\Games\RA2\ra2.exe" -speedcontrol

 

Then restart RA2. If there is no shortcut file to your ra2.exe or game.exe, you can make one by right-clicking the exe file and choosing "Create shortcut". For more info on RA2's command line options, visit: http://modenc.renegadeprojects.com/Red_Alert_2. I hope this helped.

Share this post


Link to post
Share on other sites

Right click your ra2 icon -> shortcut tab -> add the following to the Target:

-speedcontrol

 

Example:

"c:\games\ra2\ra2.exe" -speedcontrol

 

Restart RA2. You should now be able to adjust the speed in single player missions.

 

NOTE: This is for Win 7, but it should be similar for other versions of Windows as well.

Share this post


Link to post
Share on other sites

I also fixed your old post; your link to the modenc wiki had the period of the sentence stuck at the end of the link  :cncsmirk:

Share this post


Link to post
Share on other sites

I also fixed your old post; your link to the modenc wiki had the period of the sentence stuck at the end of the link  :cncsmirk:

Oh ok, thanx :)

Share this post


Link to post
Share on other sites

Legends.  Thanks guys.

 

xD Now I just need to figure out how to get the menu and cinematics to scale to 1080p instead of being small boxes.  Yuris Revenge does not have that issue.. but im thinking I can get around it by scaling it myself in the video editor if it comes down to it.

 

Edit:  nevermind seems Yuris revenge does have the issue.. aargh.. aaargh..

 

Right.. looks like I now need to figure out how to make the menus and stuff in 1080p like normal RA2 does.. otherwise recording is going to be difficult. :/

Share this post


Link to post
Share on other sites

xD Now I just need to figure out how to get the menu and cinematics to scale to 1080p instead of being small boxes.  Yuris Revenge does not have that issue.. but im thinking I can get around it by scaling it myself in the video editor if it comes down to it.

Afaik, there is no way of doing this in RA2. If you really must record the cinematics in full screen, the only work-around that I can think of is to edit your ra2.ini file, scroll down to [Video] and add 'AllowModeToggle=yes' and  also set StretchMovies to yes.

 

Example:

[Video]

AllowModeToggle=yes

ScreenWidth=1920

ScreenHeight=1080

StretchMovies=yes

 

BUT you cannot play any games (single or multiplayer), otherwise RA2 will crash. You can view/record the stretched movies by going to 'Movies & Credits' in the main menu. You'll then have to set AllowModToggle to 'no', then restart RA2 so that you can play again. So basically, you'll have to record the missions and the cinematics separately if you want both in full screen.

 

Edit:  nevermind seems Yuris revenge does have the issue.. aargh.. aaargh..

YR doesn't have this problem (not The First Decade or the xwis versions anyway). The menu and movies should be stretched regardless of the in-game resolution you're playing in.

Share this post


Link to post
Share on other sites

Just tired that extra allowmodetoggle thing and everything just seems to force to 640x400..

 

if I set everything ot 1080p red alert 2 is fine, the videos are boxes but otherwise its all still 1080p thus recordable but yeah yuris revenge the menu and everything just stays locked to 400p but the game will be 1080p ingame. 

Share this post


Link to post
Share on other sites

Doesn't "StretchMovies=yes" fix al that anyway?

StretchMovies doesn't seem to do anything unless AllowModeToggle is on.

Share this post


Link to post
Share on other sites

Neither of those stretched Yuri's revenges movies or menu for me.  but in RA2 on its own it stretched the menu and boxed the movies.

Hmmm... weird. All I can think of is that if you're using an AMD graphics driver, temporarily disable CCC. If not, try asking at http://xwis.net/forums/, there are a few RA2/YR gurus there.

Share this post


Link to post
Share on other sites

Doesn't "StretchMovies=yes" fix al that anyway?

StretchMovies doesn't seem to do anything unless AllowModeToggle is on.

Umm.... in TS I'm fairly sure those two were simply different solutions to the same problem.  O_o

Share this post


Link to post
Share on other sites

Doesn't "StretchMovies=yes" fix al that anyway?

StretchMovies doesn't seem to do anything unless AllowModeToggle is on.

Umm.... in TS I'm fairly sure those two were simply different solutions to the same problem.  O_o

I don't know, maybe WW/EA messed it up in RA2 :D

Share this post


Link to post
Share on other sites

Neither of those stretched Yuri's revenges movies or menu for me.  but in RA2 on its own it stretched the menu and boxed the movies.

Hmmm... weird. All I can think of is that if you're using an AMD graphics driver, temporarily disable CCC. If not, try asking at http://xwis.net/forums/, there are a few RA2/YR gurus there.

 

Nvidia card.  I'll go see what they say over at xwis.  thank yee

Share this post


Link to post
Share on other sites

Right click your ra2 icon -> shortcut tab -> add the following to the Target:

-speedcontrol

 

Example:

"c:\games\ra2\ra2.exe" -speedcontrol

 

Restart RA2. You should now be able to adjust the speed in single player missions.

 

NOTE: This is for Win 7, but it should be similar for other versions of Windows as well.

 

Doesn't work for me.

I saw in that original thread that they where talking about 1.0.0.6 patch, and i have 1.0.0.1, maybe that's the problem? Where can i get it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...