FunkyFr3sh

Tiberian Sun patches - Fix for the windows 8 / 10 menu problems and more

145 posts in this topic

The "official" freeware release of TS is not much more than the TFD Tiberian Sun folder dumped in a zipfile. It's kind of a mess. Which is why that installer was made in the first place.

0

Share this post


Link to post
Share on other sites

There is no "Westwood official" besides the disks. Westwood was long gone when EA made the game freeware...

0

Share this post


Link to post
Share on other sites

Guys, does anyone still have problem with scrolling at windows 10? I'm having pretty standard config via cncnet launcher, tried different options with rendering and still scrolling with one millisecond to the other side of the map.

0

Share this post


Link to post
Share on other sites

Guys, does anyone still have problem with scrolling at windows 10? I'm having pretty standard config via cncnet launcher, tried different options with rendering and still scrolling with one millisecond to the other side of the map.

 

 

Check the first post here in this thread, there are few things listed you can try

0

Share this post


Link to post
Share on other sites

Whenever I try to install the 2.03 patch i get the attached error. Any Idea on how I can fix this?

0

Share this post


Link to post
Share on other sites

Whenever I try to install the 2.03 patch i get the attached error. Any Idea on how I can fix this?

 

I think I've seen this before, but can't remember what the solution was.

 

In the worst case you can just download the single player installer from us, it has the patch already included

0

Share this post


Link to post
Share on other sites

Hello I have windows 10 , I downloaded your patch on page one of this form. the game run great but I have a scroll speed problem which makes the game unplayable its super fast , I would really appreciate if someone could help me with this issue ,this is one of my favorite games of all time. funkyfr3sh your a awesome guy to get this going nice to see other people who love this game as much as me and more Thanks 

0

Share this post


Link to post
Share on other sites

Hello I have windows 10 , I downloaded your patch on page one of this form. the game run great but I have a scroll speed problem which makes the game unplayable its super fast , I would really appreciate if someone could help me with this issue ,this is one of my favorite games of all time. funkyfr3sh your a awesome guy to get this going nice to see other people who love this game as much as me and more Thanks

 

Hey, I added a few solutions for these kind of problems in the first post, did you try them already?

 

You can find it here (scroll down to Known Problems) https://forums.cncnet.org/index.php?topic=3438.0

0

Share this post


Link to post
Share on other sites

thank you I tried turning the rendering from ddwarpper to default and disable the graphic card but now ill I get is a black screen any suggestions 

0

Share this post


Link to post
Share on other sites

thank you I tried turning the rendering from ddwarpper to default and disable the graphic card but now ill I get is a black screen any suggestions

 

Yes, that can happen in rare cases, the main use of ddwarpper is to solve such black screen problems.

Very bad luck that you have both problems at the same time, that means you'll have to try the other rendering settings. I suggest either IE-DDraw or ddwrapper

0

Share this post


Link to post
Share on other sites

Does this patch also work for Twisted Insurrection?

0

Share this post


Link to post
Share on other sites

Does this patch also work for Twisted Insurrection?

 

Nope, but you could download the MS compatibility toolkit and create a db for it with the following shims:

 

16BITCOLOR

8And16BitTimedPriSync

ForceDirectDrawEmulation

DxPrimaryEmulation -DisableMaxWindowedMode

 

 

Make sure you don't have any ddraw.dll inside of your game folder

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello, first of all thanks for the great support!

All of your patched games work fantastic for me, except tiberian sun. I have super long, roughly 2 minutes loading times. Load game, loading new maps, loading skirmish. Everywhere. Sometimes the game gets slower too. I have the cd and the first decade version. No luck either. Tried the full setup with the launcher, from here, still getting long load times. I tried every wrapper option. None of them help. Maybe someone know a solution. Just in case: My specs: Win 10 64 bit, amd x4 760k, 4gb ram, r7 260x. Thanks in advance. Ps.: Sorry for my english. 

Edited by Galacsin
Grammar
0

Share this post


Link to post
Share on other sites
6 hours ago, Galacsin said:

Hello, first of all thanks for the great support!

All of your patched games work fantastic for me, except tiberian sun. I have super long, roughly 2 minutes loading times. Load game, loading new maps, loading skirmish. Everywhere. Sometimes the game gets slower too. I have the cd and the first decade version. No luck either. Tried the full setup with the launcher, from here, still getting long load times. I tried every wrapper option. None of them help. Maybe someone know a solution. Just in case: My specs: Win 10 64 bit, amd x4 760k, 4gb ram, r7 260x. Thanks in advance. Ps.: Sorry for my english. 

I had this problem back on Win2k, it turned out being high-volume of individual custom maps. I think I fixed it by putting them into bundles, that or I deleted the ones I found uninteresting. I don't suppose you installed a ton of maps along side your individual attempts?

0

Share this post


Link to post
Share on other sites

Thanks for the tip! I don't install anything but the game. I used the patch for the cd version, or used the downloaded installer. I tried running xp in virtual machine, and of course the problem is not existed there but the game stutter because lack of processing power. It is look like a win 10 problem. Just don't know how to fix it.  

0

Share this post


Link to post
Share on other sites

Im having one problem after the next with TS. I downloaded the origin version because its free on access and such and this patch. At first i was having the no menu option which is what lead me to finding this patch. Now when I load the game I'm getting a black screen. I am running a windows 10 system. Please if you have a fix for this I'd love to know it. TS was my favorite of the C&C series.

0

Share this post


Link to post
Share on other sites
On 5/7/2017 at 0:12 PM, Galacsin said:

Hello, first of all thanks for the great support!

All of your patched games work fantastic for me, except tiberian sun. I have super long, roughly 2 minutes loading times. Load game, loading new maps, loading skirmish. Everywhere. Sometimes the game gets slower too. I have the cd and the first decade version. No luck either. Tried the full setup with the launcher, from here, still getting long load times. I tried every wrapper option. None of them help. Maybe someone know a solution. Just in case: My specs: Win 10 64 bit, amd x4 760k, 4gb ram, r7 260x. Thanks in advance. Ps.: Sorry for my english. 

 

Is it just in game slow when you try to start a mission/loading a saved game or does the game itself also start up slowly?

 

If it also starts up slowly then try to adjust your page file size, uncheck "automatically manage paging file size.." and use a fixed size for min and max value (see on the bottom which size is recommended). http://i.imgur.com/s1rM0xl.png

 

On 5/19/2017 at 0:27 PM, Harroc said:

Im having one problem after the next with TS. I downloaded the origin version because its free on access and such and this patch. At first i was having the no menu option which is what lead me to finding this patch. Now when I load the game I'm getting a black screen. I am running a windows 10 system. Please if you have a fix for this I'd love to know it. TS was my favorite of the C&C series.

Try to play around with the rendering settings in the tiberian sun config. (Use DxWnd or ie-ddraw"

0

Share this post


Link to post
Share on other sites
11 hours ago, FunkyFr3sh said:

 

Is it just in game slow when you try to start a mission/loading a saved game or does the game itself also start up slowly?

 

If it also starts up slowly then try to adjust your page file size, uncheck "automatically manage paging file size.." and use a fixed size for min and max value (see on the bottom which size is recommended). http://i.imgur.com/s1rM0xl.png

 

Try to play around with the rendering settings in the tiberian sun config. (Use DxWnd or ie-ddraw"

The game speed is depending the renderer i choose. The most stable for me is TS-DDraw, but still getting slow after 10-20 minutes. The main menu itself start fast. Other renderers than TS-DDraw had problem the load/save menu. I have to wait roughly 1 minute to show the load/save window (TS-DDraw does not have this problem). After i hit load, i have to wait 2 minutes in every renderer. The game than plays fine instantly. Just getting slow after. I tried the page file settings on manual as you suggested but sadly not made any difference. Maybe the vga driver is the culprit? I tried many different but none of them helped. Anyway, thanks for the tip! At least i know that pagefile is also can be a factor. Thank you, and sorry for my english.

0

Share this post


Link to post
Share on other sites

Hi.

 

I have downloaded the patch and it fixed the black menu problem but when I load saved games it takes forever or start new skirmish games, everything is slower. I think it's windows 10 issue

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.