Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
atenzor

AI attacks overlay...

Recommended Posts

Hi, this is weird.

 

I checked allied mission 5 where you have to rescue Tanya from the prison and then build base, etc. I noticed the overlay Chain Link Fence (CYCL) and a mammoth tank was near the walls and never attacked the overlay walls.

 

Then, I went in the editor, created a map with same overlay walls (CYCL) and only difference is instead of mammoth tank, i have 2 light tanks for the USSR and I even copied the same settings for House, IQ, unit mission type Area Guard, etc. and the light tanks always attack the Chain walls when I start the mission. I even changed to Mammoth tank and still same. Why? Even changed to concrete walls, same...

 

Is this a bug or am I missing something here? Can you guys replicate this situation and see if same happens to you unless you know right away what the problem is? thanks a lot

 

i can attach my ini mission file maybe if you want to check?

 

Share this post


Link to post
Share on other sites

did you check the text of the file, in raed you can click the T in the top right. Units can have different modes (Guard, Sleep etc..) maybe thats the problem

Share this post


Link to post
Share on other sites

did you check the text of the file, in raed you can click the T in the top right. Units can have different modes (Guard, Sleep etc..) maybe thats the problem

 

I attached the ini file, start allied mission 1 campaign to start. It's not a complete mission, I am simply testing basic mission logic before beginning anything and this is so far stopping me.... no idea what's wrong... maybe you or someone can figure this out. Does it happen in your game also? thanks

 

edit: btw, I am using RAED 1.26 and Red alert 3.03p-Iran beta 1V1 (as seen from the main menu of the game). I am running windows 7 ultimate 64-bit

scg01ea.ini

Share this post


Link to post
Share on other sites

Walls get a owner attched to them when they are close to a building. In allied mission 5 the walls in the soviet base are owned by the soviets. The walls being owned by the side with the closest buildings is hardcoded and can't be changed. It also can be a bit buggy at times. The radius of owned walls seem to be random. In a test I did I got 4 squares north of the building that were sellable to me while east I got 7 sellable west I got 8 sellable.

 

The ways to stop the AI from destroying walls is put a building it owns by them or put the below into your map. Note that if you put this into your map the AI will never destroy walls. This means you can wall the AI out of your base or wall in the AI with in it's own base like you can do in C&C95.

 

[Easy]

DestroyWalls=no

 

[Normal]

DestroyWalls=no

 

[Difficult]

DestroyWalls=no

Share this post


Link to post
Share on other sites

Walls get a owner attched to them when they are close to a building. In allied mission 5 the walls in the soviet base are owned by the soviets. The walls being owned by the side with the closest buildings is hardcoded and can't be changed. It also can be a bit buggy at times. The radius of owned walls seem to be random. In a test I did I got 4 squares north of the building that were sellable to me while east I got 7 sellable west I got 8 sellable.

 

The ways to stop the AI from destroying walls is put a building it owns by them or put the below into your map. Note that if you put this into your map the AI will never destroy walls. This means you can wall the AI out of your base or wall in the AI with in it's own base like you can do in C&C95.

 

[Easy]

DestroyWalls=no

 

[Normal]

DestroyWalls=no

 

[Difficult]

DestroyWalls=no

 

Interesting information, so to recap, either I include that code OR just build any AI owned building close and they won't attack? In any case, I will test and let you know. Thanks a lot!

 

edit: tried AI owned building and it doesn't attack walls now!

tried your code and it also doesn't attack walls now!

thanks a lot! <33

it works!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...