Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Mabus

Original maps not loading (screenshot of error here)

Recommended Posts

Hi guys,

 

So I've reinstalled CnCNet RA1 online from scratch and have created a new map, but it's not loading. Instead, I get the following error.

 

screenshot.JPG.59b7f4c57f57fb2eafb3c3fcd9e6745f.JPG

Share this post


Link to post
Share on other sites

There should be a crash log that will be needed. Also attaching the map so others can look at it may help as well.

Share this post


Link to post
Share on other sites

A crash log was sent after it crashed. Here is the map (created through the usual RA Editor application).

Caspian.JPG.6ea105e8ceecb3095f8d7bcf4bfe9ad9.JPG

Share this post


Link to post
Share on other sites

This is really weird.

The game crashed in PaletteClass & PaletteClass::operator=(PaletteClass &) so its not a trigger issue.

I just tested the map and it crashes for me too at the same address.

[Edit]

The issue is caused by the desert theater

Share this post


Link to post
Share on other sites

Maybe somthing wrong with the RA1 CnCNet Desert as it load in fine in Red Dawn 2014 using CnCNet.

Share this post


Link to post
Share on other sites

Just FYI, none of the maps I've created are working - only the stock standard RA1 ones already in the game. So it's not unique to this particular map. There's something more to this.

Share this post


Link to post
Share on other sites

Like a bolt out of the blue the maps no longer have this issue and are working fine. I didn't make any changes since my last post on here so it seems like pure luck. Thank you for your help and looking into it though. Are they still not working on your end?

Share this post


Link to post
Share on other sites

My guess is that maybe the desert theater got updated and they forgot to add the desert.pal to the desert.mix.

Share this post


Link to post
Share on other sites

It probably couldn't load the desert palette file somehow.

Share this post


Link to post
Share on other sites

I made the installers working fully offline for skirmish and LAN games, forgot to add the custom theaters and thats why it crashed. I fixed the installers now

 

The reason why it started to work for you is probably that you started the client in online mode and it downloaded the theaters

Share this post


Link to post
Share on other sites

I've modified & improved the desert palette for RA1 a while ago. Is that included in this pack?

 

bushlands.png.02b7fe570348ed5729f5971abb6b0265.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...