Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
kaspro

Limit cpu usage

Recommended Posts

I'm not 100% sure but if your CPU usage is too high it may cause overheating in some systems with poor cooling, and/or cause a laggy performance if background programs are running (if you want to play music for example)

Share this post


Link to post
Share on other sites

C&C1 and RA1 were originally made for non-multitasking systems, meaning no one gave a damn if they used 100% of your CPU. Because of that, the easiest way to slow down a game is to throw some extra calculations to your CPU so it is slower in doing everything.

 

They patched out a bunch of that stuff, using more efficient timing methods instead, so your background processes don't start stuttering because you're running a 20-year-old game :P

Share this post


Link to post
Share on other sites

What AndrewFord and Nyerguds said is true, Red Alert, cnc95 and dune 2000 had no real limiter and were using 100% of one core all the time. The main problem with it was the overheating, if the cpu was getting too hot then it would throttle down and the game started to lag. But the feature is also nice for notebooks, now you can play much longer time while on batteries. We enabled this now by default for all 3 games on every new installation

Share this post


Link to post
Share on other sites

What limiter did you add? A FPS based one or the windows message loop?

Share this post


Link to post
Share on other sites

I couldn't use my FPS limiter from dune 2000 since the games already had a limiter, it's the sync_delay function. So I just inserted a sleep there and also in a sleep in every dialog like westwood did in the WOL dialog. We got the repos moved now since bitbucket had that annoying 5 user limit, I can give you access if you wanna look

Share this post


Link to post
Share on other sites

sure, didn't know bitbucket had that gay limit.

 

Does sleep work just fine? so you're just syncing by frames per second in sync delay?

Share this post


Link to post
Share on other sites

yeah, we had to add/remove everyone there non stop since all repos were full

 

I just let the game do the math, it will continue to call the input function while it waits to waste some time, so I just inserted a sleep there, this also slowed down the scrollrate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...