Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
ROB

AI Wont Build

Recommended Posts

I cant even believe I'm having this sort of issue. This suddenly stopped working for no apparent reason, I only added 2 looping patrols. It should be working, I can find nothing wrong in the logic. Been fighting it half the day and ran out of patience. AI wont build new units for teamtypes. I don't think it's a production or Autocreate issue, I set all that correctly. I'm ready to delete the shit and move on, I'm not doing something twice from scratch. Can anyone see anything wrong maybe?

scg01ea.ini

Share this post


Link to post
Share on other sites

I never use Event 1:  Any Event I would change this to Event 1:  Elapsed Time (1/10th min)... 1 for the production/Autocreate trigger. Also adding the Prebuild team members before team is created my be helpfull.

 

The Change Formation to... I have never seen used in any stock missions so this could be a prob.

Share this post


Link to post
Share on other sites

It was set to elapsed time 0, made no difference. Prebuild makes no difference. The formation was working fine before, it makes all units go the same speed. I had autocreate disabled and that makes no difference. Only units already on the map are used. AI wont make anything. Im done with this nonsense, already deleted all scripting. shelving the map and moving on...in a few days when im not pissed at it anymore.

 

Its like there is an invisible variable keeping AI from making things. It does not matter how many triggers or teamtypes you change, something gets stuck somewhere in the map bits. I've seen this over the years. Only way to fix it is to start over.

 

EDIT:

So I remade all triggers/temtypes related to USSR production and nothing happens, disproving my theory.  :ranting: stupid ridiculous. If nothing is technically wrong. Are there multiple versions of RAED? Perhaps I have a buggy one.

scg01ea.ini

Share this post


Link to post
Share on other sites

It's obvious. There are too many enemy infantry on map.

Add MaxInfantry=200 or more to [uSSR] section.

 

Original scg01ea have 150 infantry cap, may be because of this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×