Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Duxopes

Allies in skirmish

Recommended Posts

Hi everyone!

I dont know if this has already been adressed. Couldn't find it with the keywords I thought relevant in search. But I was playing a skirmish, trying to get back in the game a bit after years. So with the launcher you can add allies which I did and made a 3vs2. Now to the point: When my ally cleaned up the second AI after he got income deprived the player defeated notification showed up. The ringer is immediatly after my ally turned hostile which did not happen after the first AI was defeated, I was wondering if this is intentional to give more of a challenge or if this is a byproduct of TibSun origionally having no team up system in skirmish? Well it wasn't a problem gameplay wise because I just bombed him to oblivion but still it seemed weird. I must add that I saved the game and continued a day later which might have something to do with this since I didn't finish it in one session since I was taking it slow.

Let me know it would be much appreciated! :D

Share this post


Link to post
Share on other sites

I don't understand the scenario fully. Did you have 2 humans in the game? And one human declared war on you and attacked?

Share this post


Link to post
Share on other sites

Its skirmish, not multiplayer. I thought that was obvious enough in itself. I'll recap again: 5 total player, im the only human, 2 AI die, my ally betrayed me somehow and so it went from a 3vs2 to a 2vs1. Hope this is clear now.

Share this post


Link to post
Share on other sites

did you accidentally click on one of  your allies units and press "A" that would declare war on them i don't think ais have the capability to declare war on other players.

Share this post


Link to post
Share on other sites

No I did not, it just happend immediatley after the AI was defeated like it triggered it. I noticed them starting to attack my harvesters and that I was able to target them. I even reloaded the save to check and it happened again, after which I deprived them of their mcv and refs out of necessity. But yeah it seemed weird since it didnt happen after defeating the first ai. Trust me that this wasn't player instigated.

Share this post


Link to post
Share on other sites

Had another game, 3vs3 (others all AI again). And it happened again, still don't know what caused it. When the second enemy AI got defeated my two allies instantly turned hostile again so it seems coded (somehow anyway). Can anyone please tell me if this is intended or known? Still didn't get an answer. :(

Share this post


Link to post
Share on other sites
5 hours ago, Duxopes said:

Had another game, 3vs3 (others all AI again). And it happened again, still don't know what caused it. When the second enemy AI got defeated my two allies instantly turned hostile again so it seems coded (somehow anyway). Can anyone please tell me if this is intended or known? Still didn't get an answer. :(

Some games have an "Allied Victory" box you have to tick when making the game, otherwise when your opposing team is defeated, your alliance breaks and you have to kill the remaining players, computer controlled or otherwise.

Not sure if Tib Sun has that, might be worth checking.

Share this post


Link to post
Share on other sites

its a bug I think, play FFA you see the exact same, one player gets defeated, then everything comes at you, even Hunter seekers.

Share this post


Link to post
Share on other sites
Posted (edited)

Can't believe that no one recognizes the situation. If other AI players attacks you after one is dead you have set [AI] Paranoid=yes. And yes, it is set to be that by default.

This is what rules.ini says about that key:

Quote

Paranoid=yes            ; Will computer players ally with each other if the situation looks bleak?

So basically just set it to no if you want to reserve allies after one AI is dead or some of ally relationships change (basically ally/unally in multiplayer).

Edited by PTapioK

Share this post


Link to post
Share on other sites
Posted (edited)

that is the default then, it wasn't set to happen on the original, and oddly enough I was looking for .ini file last night and couldn't seem to find any rules.ini to change, managed to download the .ini and change that line, and it does indeed fix it.

 

 

Edited by ScottO

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×