Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
InfraredEcho

Creating teams, with existing units

Recommended Posts

Red Alert 1 mission creation:

I am trying to create a team using the 2 rangers in the screenshot below, which will be triggered when the player enters the base via the west.

I have followed the instructions that come with the editor using the examples provided but cant seem to get it to work.

 

These are the trigger/team lines i have so far which is no different from what is in the examples/tutorials

------------------------------------------------------------------------------

Name:      Ranger1
Owner:     Special
Existence: temporary (any linked event -> switch, destroy)
Type:      simple (event1 => action1 [+ action2])

Event 1:   Entered by...Multi1


Action 1:  Create Team... Ranger1
Action 2:  Reinforcement (team)... Ranger1

Linked to: CellTriggers - 1
           Units - 2

------------------------------------------------------------------------------

Name:     Ranger1
Owner:    Special
Priority: 7
Max:      0
Num:      0
WayPoint: 30

Team:     Ranger                2

Orders:   0 Move to waypoint... 30
          1 Move to waypoint... 31

Options:  Charge toward target ignoring distractions.

Linked triggers: Ranger1
-------------------------------------------------------------------------------

trying to get them to patrol a road north and die in an ambush starting another trigger to lead the player to their next objective.

 

im probably missing something but i just cant find out how to make this work

Team creating.png

 

currently the rangers just sit there and do nothing, still cant figure this one out

Edited by InfraredEcho

Share this post


Link to post
Share on other sites

It doesn't matter if the trigger is linked to the units.

- Make sure, the unit's mode is "guard". everthing else doesn't work. 

- Entered by "Multi1" may be another reason. I don't know if this trigger event works with multi houses.

- Triggers in official RA missions have a maximum of  only 4 characters. I never tested if more than 4 work anyway.

Are there more than one rangers on the map?

Edited by Messiah

Share this post


Link to post
Share on other sites
15 hours ago, Messiah said:

It doesn't matter if the trigger is linked to the units.

- Make sure, the unit's mode is "guard". everthing else doesn't work. 

- Entered by "Multi1" may be another reason. I don't know if this trigger event works with multi houses.

- Triggers in official RA missions have a maximum of  only 4 characters. I never tested if more than 4 work anyway.

Are there more than one rangers on the map?

-do you mean the unit on the map or the unit in the team defining window? units as they are on the map are in guard mode

-not sure if or why it would be unique to various triggers, but i have quite a few other triggers that work with multi1 fine

-they are the only rangers on the map

Share this post


Link to post
Share on other sites

On the map. Usually the game picks that unit most close to the waypoint. You can remove the ...move to waypoint 30 scriptline because your units are already there. How far is waypoint 31 away? It might be a too long distance or complicated way.

I remember there was an issue that CellTriggers won't work with Multi houses. I usually avoid these multi houses in SP missions generally, as they don't have a defined side and sometimes have a weird behavior. Use Spain or Special instead.

Share this post


Link to post
Share on other sites
On 3.6.2017 at 6:12 PM, Messiah said:

On the map. Usually the game picks that unit most close to the waypoint. You can remove the ...move to waypoint 30 scriptline because your units are already there. How far is waypoint 31 away? It might be a too long distance or complicated way.

I remember there was an issue that CellTriggers won't work with Multi houses. I usually avoid these multi houses in SP missions generally, as they don't have a defined side and sometimes have a weird behavior. Use Spain or Special instead.

I wrote my problem into an another section, but luckily i found this topic. In my map, there is three 1TNK placed on Guard -mode with teamtypes and they get confused. Have you ever encountered same kind of problems?

Share this post


Link to post
Share on other sites

Yes.

In that case just reinforce the teams first and loop then. Reinforce team from map edge (or boat, or paradrop plane) and add the script lines for patrolling then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By untitled83
      I'm trying to play ra1 online. I click on the "Play Online" which attempts to launch cncnet5.exe but it doesn't launch. The event viewer shows the following 2 events when i try to run the game
      Event 1
      Level: Error  Message: .NET Runtime version 2.0.50727.9151 -  Source: .NET Runtime ^^^ Not a very informative error
      Event 2
      level: Information source: windows error reporting Message: Fault bucket 1500961723287199156, type 5 Event Name: CLR20r3 Response: Not available Cab Id: 0 Problem signature: P1: cncnet5.exe P2: 5.0.0.0 P3: 5f4f87ab P4: cncnet5 P5: 5.0.0.0 P6: 5f4f87ab P7: 2 P8: 61 P9: FatalError P10:  To be fair, I'm a developer and i've got a .net development environment going (this is my work laptop as well) with every possible .net version for various reasons.  I've installed and uninstalled .net 3.5 a few times but still no success.
      Do we know if/when there will be a .net 4.5 version of cncnet?
       
    • By Brainiac
      Does anyone else have this problem after the last update?, i cant play.

    • By PizdaDestroy
      When someone starts a game my game crashed and it says ''Exception has been thrown by the target of an invocation''
      Please help.
    • By Salvation
      Hello guys!
      I had a weird a weird issue.
      I'm currently developing a next version of CCRDX mod and i modified one civilian slot (C3 known as Shelly) as a buildable unit. As rules.ini i turned a value NamedCivilians=yes and with Ingame Strings editor i edited conquer.eng Shelly's name as a suitable unit name. Let's just say that Shelly is no more Shelly but her in-game name is Sniper.
      A few days ago i was testing a mission which had a Desert theater and i found out that if NamedCivilians is turned on, some of the civilian building names are really weird, such as "are you propse a draw?", etc.
      -> clicking on that building crashes game immediately.
      -> But when namedcivilians is turned off, the building name is "civilian building" and game won't crash anymore.
      -> But if NamedCivilians is turned off, my C3 slot unit name is "Civilian" and i can't edit the name. This is a quality issue.
       
      Any ideas how to fix this issue?
      My goal: I want that each civilian building has a name "civilian building" and game won't crash and also i want that my C3 unit in-game name is Sniper.
      What i know is that editing rules.ini putting the name tag on a certain building can fix this, but it can also cause many crashes making my mod non-playable. I also tried to make a list of every Civilian building, put the Name=Civilian Building on it and insert these values under certain mission file, this worked 50-50.
       
      I'm using Iran's PortableRA
    • By [GL]FaLCoN
      https://youtu.be/2xXnAxEfZZI
      in this video there is my problem:
      the problem is not in the internet ... this problem gets with me. if i turn on the device and enter the game quickly, i get this problem
      this problem occurs to me for a long time ... i have been using a laptop and this problem occurs to me, and now i am using a desktop machine which is much more powerful than my previous laptop and so far this problem occurs to me.
       
      thank you for your cooperation <3
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...