Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Bengolly

Gray bar on Tiberian Sun menu?

Recommended Posts

if fails, Try VMWare, If it fails too, sorry, but you are out of luck :(

 

Or VirtualBox which is free :P

Share this post


Link to post
Share on other sites

I downloaded Oracle_VM_VirtualBox_Extension_Pack-4.1.8-75467.vbox-extpack but I cant install it as it says unknown extension does anyone know how I install it ?.

I had an hour long screen sharing session with a Dell technician yesterday to try to fix this issue, hes going to look in to it, I am managing to play just by minimising to windows to get through the menu options.

Share this post


Link to post
Share on other sites

The virtual box did not work, is it just the NVIDIA cards that have the incompatible chipset and does anyone know if it is all the NVIDIA cards or just some if so does anyone know which chipset or cards as I will most likely buy another computer to play TS on and I don’t want to buy another incompatible laptop.

Share this post


Link to post
Share on other sites

Sorry for bad english.

 

I have laptop and windows7, if for you dont work power mng soliution set to high performance, try this:

 

1. run "tiberian sun" in windowed mode, just create shortcut with "-win" key, key must be in the end after double quotes

examples: "path_to_game.../game.exe -win"

2. run it, then you select some menu will see grey bar, now you need just refresh game window, just draggame window a little bit.

 

yes its annoying  :ranting: but better then nothing.

Share this post


Link to post
Share on other sites

-win? But that only works on 16-bit colours :|

 

Yes its works on 16bit, this is a price if you have laptop and radeon video card :down: (i think is reason for problem)

at home i use one of linux distribution, so c&c working normal (using "wine")

i will try search for workaround 16bit later, if its possible, now i dont have time.

 

 

Share this post


Link to post
Share on other sites

It isn't to do with the graphics card, i have upgraded from a MSI (nividia) Card to a Radeon (Amd) and the problem is present on both and my atom netbook.

Colour depth is the problem and the only viable solution is to either force the window TS is running in to use 16bit colour (which i don't know how it would be possible) or to simply run everything in 16bit colour. The Colour depth handling is a problem with windows [xp?] vista and above.

wine emulates the required environment so will be emulating 16bit colours for TS within the window eliminating any problems.

Share this post


Link to post
Share on other sites

It isn't to do with the graphics card, i have upgraded from a MSI (nividia) Card to a Radeon (Amd) and the problem is present on both and my atom netbook.

 

It should be obvious when a fix is to disable DirectDraw acceleration on computers that allow that (That's what the ddraw.dll that floated around did). TS problems seem to be concentrated on mobile GPUs, but some desktop GPUs suffer as well.

 

TS runs fine on my desktops Radeon and my netbooks GMA, but not my laptops GeForce. Though the issues are no consistent with a particular brand of GPU since all brands seem to have GPUs that TS doesn't like.

Share this post


Link to post
Share on other sites

It isn't to do with the graphics card...

 

Low price or integrated card only for desktop.

p.s. MSI (comp), Radeon (card) :down: (its only my opinion and experience)

 

Colour depth is not problem, you can change your desktop to 16bit on win xp, w7 (dont know about vista, but theoretically it can)

 

Wine emulate everything (almost), TS working because its translate directx to opengl

 

It should be obvious when a fix is to disable DirectDraw acceleration on computers that allow that.

 

Hmm ..., i can disabe DD on W7, so we need new game launcher to emulate DD=disabled.

Share this post


Link to post
Share on other sites

Hi guys, this may be my first post here, but I assure you, it's legit. I've been having the same problem, which has rather interfered with my quest to complete all missions of all games in the series in Hard Mode (where available). It turns out, the problem is to do with the refresh rate of Win 7. This explains why minimising and then maximising again the game window causes the menus to show up again.

 

The solution is to create a dummy second screen, even if you don't actually have one. By running the game from a fake second screen, extended onto the first, it works. I also hear this solution works for problems with Red Alert 2 on TFD on Win 7. http://img4.imageshack.us/img4/7223/tutorialcopy.jpg Note that this originally came from the C&C forums, here: http://www.commandandconquer.com/forums/showthread.php?1600-DX-problems-with-ra2-yr-and-tsun-on-Windows-7 (the second last post by user Weiss specifically). It's the only confirmed solution I've found that doesn't involve a virtual machine. I'm using an Asus N55F with Win 7 64 bit, the direct x solution didn't work and I can't disable Direct Draw on it.

 

One last thing - this solution works for both the standard TFD installation of the game, and the direct installation package that's pre-patched for Win 7 play.

 

Hope this helps people experiencing the same problem as me!

Share this post


Link to post
Share on other sites

One last thing - this solution works for both the standard TFD installation of the game, and the direct installation package that's pre-patched for Win 7 play.

Obviously. They're exactly the same thing :P

 

Anyway, thanks for this! It'll be really useful for people :)

Share this post


Link to post
Share on other sites

Hello everyone,

 

I just registered on this forum to share this with you.

After months and months of trying to find the solution for those who have issues with direct draw (aka screen freezes), I finally found it:

 

- Right click on desktop->screen resolution

- Click the Detect button. Unconnected screens will appear.

- Extend desktop to a VGA connection on the Intel GPU

- Drag the 2nd screen to the corner of the primary screen so the mouse  boundaries of the primary screen will remain (almost) the same.

- Click OK/Apply

 

Thanks to http://communities.intel.com/message/147706#147706

 

This issue seems to affect those who have laptops with switchable graphics.

 

BTW: Registration questions are awesome.

Share this post


Link to post
Share on other sites

I have found a fix for this problem, I have spoken to two Dell representatives and search the whole internet for three years to find this fix so you could imagine my disappointment when I got to this website and found it harder to log in or reregister than to get in to any of my on line bank accounts, whats with all the security C&C its not helping keeping the old games going.

 

Share this post


Link to post
Share on other sites
On 9/7/2012 at 10:09 PM, SPQR-Caligula said:

I have found a fix for this problem, I have spoken to two Dell representatives and search the whole internet for three years to find this fix so you could imagine my disappointment when I got to this website and found it harder to log in or reregister than to get in to any of my on line bank accounts, whats with all the security C&C its not helping keeping the old games going.

 

 

true, i remember when I registered here and couldn't answer the question (it was a different one back then) I just rage quit after few failed attempts and then like a week or so later I decided to try again and after some google search i could answer it..

 

Share this post


Link to post
Share on other sites

I just read the post 3 above and that’s how I have done it to I connected a second monitor to the laptop vga out socket and have a clone display, it stops the gray bar problem on both displays.

Share this post


Link to post
Share on other sites

Hi, it's me again, unfortunately I'm now having an issue with my own solution and cannot for the life of me think how this is or what I can do to fix it!

 

I can get to the point where I need to select "extend displays" this is all well and good except that the screen I actually see is the blank second screen, and I have no way of pulling things across so I can see the screen resolution update window to fix anything. I'm sure I never had this before, but it is the same computer.

 

Can anyone please help?

 

EDIT: Nearly had a heart attack when I managed to somehow restrict myself ONLY to the second desktop - and thus couldn't revert because everything turned up on the other, including the task bar and everything when pressing Cntrl-Alt-Del. Somehow managed to get it sorted in the Windows Controller Debugging version of safe mode, and on trying it again (I'm insane, I know) it's worked. Strange, that...

 

Also, this solution should work for C&C Ultimate Collection games - it's a lie that they've been updated for Windows 7, it's actually the exact same version as all the others with all the same problems.

Share this post


Link to post
Share on other sites

Another temporary solution:

 

This issue has irritated me for years as this is a game I loved since it came. As few of you have already said, it seem to be related to graphics. I tried direct draw patch, graphics patch, setting power to high performance etc. but nothing worked. Then I accidentally found a solution for the gray bar.

 

I have a HP dv7t which has HP on-screen display feature for sound, touch pad enable/disable etc. so when the gray bar appears, all I had to do was to press some key to get the on-screen display show something. Hope this helps someone.

Share this post


Link to post
Share on other sites

I want to say thanks to you guys, I fixed my TS menu glitch base on your replies

and my tutorial was based on your replies too

Thank you

and Thanks to CnC-Comm

You are the best

keep it up

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...