Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
FunkyFr3sh

New cnc-ddraw release (Red Alert 1 & C&C95)

Recommended Posts

1 hour ago, Lightning Hunter said:

How do I take a screenshot in C&C?  I never was able to... I read Nyergud's tutorial once, but all I ever get is a completely black image when I use print screen (no image data at all).  Also, his palettes cannot be imported by photoshop.

I tried turning on integer scaling with 960x540, but there are just black bars on top, bottom, and the sides now (the game is centered and looks tiny).  Is there a certain combination I need with maintas and fullscreen?

Edit: So I just figured out that pressing print screen while in-game creates a screenshot in the C&C folder, but all the screenshots look the same no matter what shader I'm using (so I guess it does not capture shaders in the shot).  Even xbrz-freescale.glsl looks the same in the screenshot.

 

Probably the most simple and fail-safe way is to set the display mode to "borderless" and then press Alt+PrintScreen

 

I just made a video of all shaders btw:

http://cnc.cloudns.pro/Test/index.php?video=RedAlert_Shader_Comparison.mp4

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, FunkyFr3sh said:

 

Probably the most simple and fail-safe way is to set the display mode to "borderless" and then press Alt+PrintScreen

 

I just made a video of all shaders btw:

http://cnc.cloudns.pro/Test/index.php?video=RedAlert_Shader_Comparison.mp4

Nice comparison video!  I wonder why the shader I posted above doesn't work for you?  It is now actually my favorite, and I found one in the same "series" I like even better:

https://github.com/libretro/glsl-shaders/blob/master/windowed/shaders/lanczos2-sharp.glsl

I think this shader and the other one I posted is related to all the "jinc2" shaders, although some of them make the game washed out.  The one I just put has a very sharp, clear look without being too gritty or washed out.  It makes the game look more war-like in my opinion, which suits C&C more than even the original appearance!

I also tried Alt + Print screen, but it had no effect.  Screenshots only appear as PNG in the main C&C folder when I hit print screen alone, and they seem to remove all shaders for the shot.

Edited by Lightning Hunter

Share this post


Link to post
Share on other sites

Oh yeah, I know that one. It's similar to cubic, maybe a bit sharper.

 

For screenshots you have to press Alt+PrintScreen and then make a new forum post here and press Ctrl+V (There will be no file)

Share this post


Link to post
Share on other sites
Posted (edited)

Hmm, the image appears as black when I paste it.  I can't get anything to show up.

Anyway, I think the shader is quite a bit different from Cubic (at least on my version).  Cubic is a bit too blurry for my taste.  lanczos2-sharp.glsl does a good job keeping the sharp look while also offering more of a war-like photographic feel.

Edited by Lightning Hunter

Share this post


Link to post
Share on other sites

Thanks so much for the continuing efforts here! I lost hope that I could get C&C95 Gold to work again, but now it's amazing. I donated to CnCnet so thanks so much for bringing back the memories!

I am slowly figuring out how to tweak things so works better for me. Is there a readme file that explains the ddraw.ini parameters?

I am having a wierd issue where, after playing for a while, I can no longer use the menu because my cursor disappears when the "esc" menu opens.

I've set maxfps to below my refresh rate, singlecpu to false, and set vhack to true. Windowed and Maintas and boxing is false. fullscreen is true+windowed=false.

Any idea why, after I play for a while, I lose cursor function when the menu is open?

In previous posts, there are images of a different configuration program. All I see if the CCConifg.exe, it is like the old one. Is there a different config program for me to use?

Thanks for your effort and time! Very much appreciate it.

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Skybee said:

Thanks so much for the continuing efforts here! I lost hope that I could get C&C95 Gold to work again, but now it's amazing. I donated to CnCnet so thanks so much for bringing back the memories!

I am slowly figuring out how to tweak things so works better for me. Is there a readme file that explains the ddraw.ini parameters?

I am having a wierd issue where, after playing for a while, I can no longer use the menu because my cursor disappears when the "esc" menu opens.

I've set maxfps to below my refresh rate, singlecpu to false, and set vhack to true. Windowed and Maintas and boxing is false. fullscreen is true+windowed=false.

Any idea why, after I play for a while, I lose cursor function when the menu is open?

In previous posts, there are images of a different configuration program. All I see if the CCConifg.exe, it is like the old one. Is there a different config program for me to use?

Thanks for your effort and time! Very much appreciate it.

 

Thanks!

 

Nope, there isn't a readme file currently but the latest config program should have all the important settings, you can find it here: https://forums.cncnet.org/topic/8821-cc-1-tiberian-dawn-installation-on-windows-10/ 

Usually you just keep it all on default settings (unless you might want to have some fancy opengl upscaling...)

 

The cursor issue is related to multi core cpu's, make sure you have singlecpu=true set and then it shouldn't happen anymore.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 10/17/2019 at 6:55 PM, FunkyFr3sh said:

 

Thanks!

 

Nope, there isn't a readme file currently but the latest config program should have all the important settings, you can find it here: https://forums.cncnet.org/topic/8821-cc-1-tiberian-dawn-installation-on-windows-10/ 

Usually you just keep it all on default settings (unless you might want to have some fancy opengl upscaling...)

 

The cursor issue is related to multi core cpu's, make sure you have singlecpu=true set and then it shouldn't happen anymore.

 

Thanks!

Unfortunately, the new video stuttering, which I didn't have before, began once i set the singlecpu=true

The cursor freeze on menu display rarely happens, mainly when I play for a long time. So, I guess some sort of wierd "traffic jam with memory allocation".

This was on my older laptop, used a Intel Core2 or something with win7 64bit, can't remember much else off hand.

I got my new windows10 laptop today with the i7 and not had a single problem. Seems odd to me this game runs much smoother on this i7 win10 64-bit machine.

Guess might just be a problem with my older machine since i have been using it for over 15 years.

Thanks again for all your efforts! I look forward to them.

Edited by Skybee
spelling
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By FunkyFr3sh
      All maps that receive more than 50% of the votes will be added. If there is none then the two maps with the most votes will be added only.
      Poll will close automatically in 1 week.
       
      This poll is for ladder players only, please don't vote if you're not interested in playing ranked games!
      https://ladder.cncnet.org/ladder/11-2019/ra/

    • By FunkyFr3sh
      We're going to have a ladder map poll soon, you can suggest maps that should be added to the poll here.
      If it's a new/unknown map or a modified version of a original map then please add a screenshot.
       
      https://ladder.cncnet.org/ladder/11-2019/ra/
    • By Tiny_mario
      Is this one ddos me or what. Cos i  hardwired to the internet with 300 down and 20 up no throttle no vpn
       
       
      Unable to read data from the transport connection: An established connection was aborted by the software in your host machine
    • By Skybee
      Hello again!
      I have been working on salvaging old computers from my closet so my crew can enjoy some C&C95 together.
      On my old GatewayCx210x, windows XP Sp3, machine, C&C95 Gold works great until I shutdown or restart the computer. Then, after I do a shutdown/restart, I return to open game and nothing happens. The game is in the task manager process list, but never actually opens anything at all. To fix this, I have to uninstall/reinstall C&C95 Gold. I used Nyerguds installer from http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/
      Is this an installer problem and should I try a different installer? What should I do?
      This is just an annoyance. Besides this, the game continues to process great without any weirdness.
      Thanks for any help, appreciate it.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...