Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0

Mental omega client cannot launch ?



After posting on Revora Net in M.O. client launch issues, i was told to seek a user named Rampastring on these forums.


The problem is with the client that launches the actual mod, i never actually managed to get even to the menu of the game.

Everytime i launch it, a picture pops up with the allied unit in the skies, then it stops responding on itself (Without me doing anything) and PC terminates it and asks me if i would like to send data to Microsoft about the crash (For some reason ?)

So far i tried this

- Restart of PC

- Reinstalation of RA2 YR

- Setting the compability of both client and syringe exe to SP 3 or SP2, also giving both of them admin access, neither worked

- Game is patched to 1.001

- Game is installed as part of the First Decade

- Disabling anti virus (Avast)


It does generate a log though !  i put the latest one in attachments


What i would need is the examination of the log, to find out the main source of the issues.

Share this post

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Your Windows 7 installation is corrupt. Particularly, you're missing the "Task Bar Communication" {56FDF344-FD6D-11D0-958A-006097C9A090} COM component.

Try opening a command prompt with administrator rights, and then run the following command

sfc /scannow

Keep an eye on it to see if it reports any corrupted files. Check if the client works afterwards.

Edited by Rampastring

Share this post

Link to post
Share on other sites
  • 0

Nothing worked, with some more research i found that the files were quarateed by overzealous adwcleaner, but i have no way of getting them back (And no, i wont reinstall the windows for just one mod)


The scan itself even with full admin rights didnt found anything and mod still crashes on startup


56FDF344-FD6D-11d0-958A-006097C9A090 is the registry thingy thats probably missing (I have 0 clue about this so bear with me:(

I saw some people just uploading these file, but all links i found are expired so i dont know what to do now







Edited by Mrvecz
Cleaning things up

Share this post

Link to post
Share on other sites
  • 1

If you have another Windows 7 system and know how to use regedit, you can try taking a look at HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}, back up that registry hive and then restore it on the problematic system. Taking the hive from a Windows 8 or 10 system could work too.

If your Windows 7 is 64-bit, you might also need to restore HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}.

Share this post

Link to post
Share on other sites
  • 0

When i try to import the missing (Well its not really missing, i managed to find it but its probably corrupted or something) registry from other W7 PC it pops a error saying that it failed importing (Register failed to import all data, some keys are already opened by the system or other processes ?)


Theres a odd thing, if i delete the register thingy with the task bar com file from it and try to import the "Repaired" fixture from another PC, it pops the message above. If i import the backup i made, it imports just fine.

The main thing is that the "fixtures" have different text in them, adding this text from the gut registry thingy to the corrupted registry thingy (Aka just replacing every text with the gut one) renders the file impossible to import.


Kinda wish Mental Omega just have a freakin exe to launch, i am not eager to play MP in it anyway 



Edited by Mrvecz

Share this post

Link to post
Share on other sites
  • 0

I solved it

Thanks you SOO MUCH for your help ! :)

It took some time but i managed to snatch these files from a passworded computer that was x64 and now its works... and is stable

Now only some resolution tweaking is in order, but thats trivial stuff.

So once again, thank you




  • Upvote 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By NightShadow
      I recommended my friend to update YR to play online on cncnet. At first he can play with me normally, but 3 days after installed the program this happen to him

      How can this problem be solved? He's very frustrated because it is suddenly happen and he doesn't want to quit YR. Please help.
      p.s. he doesn't have an account on cncnet community, but if anyone who can help him and wants to talk to him. I'll tell him to register on this site.
    • By tarahcip
      I tried to install the game but it always show this pop-up.
      I had tried to install, but neither a New Folder or Default Setting works!
    • By Generalslavik
      When i press the esc key in quick match to admit defeat, my screen freezes, when i finish the game, the screen that shows your kills etc is blank and i cant see my mouse. and fixes for these?
    • By Tendi54
      Yuris Revenge Quick Match Ladder  1on1
      why do i loose points if the other player "bail", the game didnt get started "properly"? i was in the game but mcv didnt deployed, then abort screen from the opponent and i get the loose? this cant be for real..
      is this a bug in the ladder that the ladder randomly roll the dice who will get the loss?..
    • By The_BlackToteM
      I have made a map that use Civilian/JP side to attack everyone when condition was met.

      It's went fine but the problem is player's (+Computer) defenses and units won't automatically attack Civilian's unit as they are in range of fire.

      So, Is it possible to solve this problem?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...