Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
ChronoSeth

RA Singleplayer Map Bug

Recommended Posts

Just when I think everything works properly, something goes wrong. :ranting:

 

For no obvious reason, the allied faction in my map is building soviet units. I've set the IQ to 5, and it's still building the units I've set it to via triggers (though I guess they're being blocked by the production of other units). Oh yeah, it builds structures which I never told it to. These are the only things stopping me from officially releasing it.

 

Things I think I might have done wrong:

-Allied house  = GoodGuy (couldn't find another house with a blue remap besides the MultiX houses) Turns out the right house is Greece... :dry:

-GoodGuy IQ = 5 [Edit] Turns out it was this, but it still doesn't explain why they were building sviet units...[/edit]

 

Map:

scu01ea.zip

Share this post


Link to post
Share on other sites

Bah, new problem. The AI is building the right units, but does nothing with them. Do I need to manually tell them to create the teams via map triggers?

(never had to do that in C&C IIRC)

Share this post


Link to post
Share on other sites

Not a clue, sorry... never made RA missions.

 

But in C&C you always have to do everything manually unless you use the Autocreate trigger.

Share this post


Link to post
Share on other sites
unless you use the Autocreate trigger.

Which is exactly what I'm doing... Maybe the movement commands of the teams are bugged...

Share this post


Link to post
Share on other sites

Well talking about C&C1, Autocreate doesn't work unless Production is activated too.

Share this post


Link to post
Share on other sites

From what little I know about C&C95 maps. RA-1s are just about the same. In RA-1 maps have a lot more options for what a triggers can do.

Share this post


Link to post
Share on other sites

Nyer, I think you misunderstood...

The AI is building the right units' date=' but does nothing with them.[/quote']

 

I am having no problems making the AI produce the units from the teams. However, the units in the teams simply sit in front of their war factory, doing nothing. (obviously not what I want them to do)

I know that I have the movement commands right, because at one point they did build the taems and the teams attacked me (though at that point I had other problems).

Share this post


Link to post
Share on other sites

Well, from what I know in C&C, the teamptype options themselves determine if a team's units are produced or not. The "Create Team" triggers determine when it'll use these units to form an actual team and execute the commands in the teamtype.

 

In contrast, a team that isn't set to be produced will be assembled from available units on the map when the "Create Team" triggers is fired.

 

and "Autocreate" is just an automatically repeating randomly-timed "Create Team" trigger with a pool of teams to choose from on each execution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...