Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...

Networking issues with Red Alert and Multi-user PC setup


Noddynod443
 Share

Recommended Posts

Hello folks,

I wanted to ask if anyone has any thoughts on a strange networking issue...My problem with C&C Red Alert 3 is centered around LAN networking. I recently bought a multiseat gaming software called "softxpand".

Softxpand Link: http://miniframe.com Youtube

"demonstration" Video: https://youtu.be/Z1OFJtXSWHU

The Multiseat gaming software with the addition of an extra monitor, keyboard, and mouse; turns one computer into two or more "workstations"/virtual computers depending on how many GPUs and monitors you have. So two or more people can play from one computer. I have my desktop PC setup for two players... I have been testing several games; with red alert 3 LAN, I get a "same CD key error", which I understand the cause of that. So I got a second copy of Red Alert 3 from ebay and installed it to a separate location on the hard drive.

The two "workstations" are now able to join to each other(LAN lobby) by LAN server; however the joining player( "player 2") can not click the "ready box" because it is "gray" not "selectible". Therefore "player 1" (the host) can't start the match... unless all the human players click that "ready box". Also "player 2" has the option to add/remove the A.I. players as the host (player 1) can do; however any such changes by player 2 (the joining player) only last for less than half a second before reverting back to the original set value... I believe the game "thinks" that the two players from the same computer are both the host of the "LAN server"... That would explain why the joining player (workstation 2) does not have the option to select the "ready box" and has the ability to make "host only" changes to the server/LAN lobby. I think some solutions to this networking problem could be:

1. Changing the gameport value for one of the two copies of Red Alert 3 so that both are not getting problems from trying to join through the same gameport. (Changing the gameport value of one of the "workstations" fixed LAN networking problems with CnCnet for Tiberian Dawn, Red Alert 1, Tiberian Sun; I just don't know how to change it for Red Alert 2 or 3)

2. Or maybe someone could make a fix/patch that bypass/overrides the need for all players to select the "ready box" therefore the host can start the match when ever he wants to.

If Someone has an idea please help solve this problem. Thank You :) , Noddynod443

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...