Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...

How to play full screen in campaign mode?


RC1985
 Share

Recommended Posts

On 3/22/2019 at 5:42 AM, RC1985 said:

Omg this worked! I mean changing the cnc-ddraw.ini method. Thanks fireworks and cmdr for the suggestions, I'm keeping them as backup plans. dkeeton: Do I still need to use the new ddraw version you showed?

Also I noticed a few things:
1. The game speed can't be changed for campaign mode?
2. There's a lot of scroll lag, in TS this can be changed with an ini file with an option 'scrolldelay' or something. How do I fix this in RA2?
3. The placebuilding hotkey, is it 'PlaceBuilding' in keyboard.ini like in TS?

adjmouse=no

 

Link to comment
Share on other sites

Hey RC, I've done some tinkering around. Try the German patches, they're super easy to unpatch so it won't hurt to try.

For YR 1.001 the German patch seems to work fine for mouse issues - now the only problem that exists is with loading and videos, the only solid response is from this forum:

On 11/14/2015 at 12:10 AM, tomsons26 said:

You can only set the menu resolution in RA2. In YR it's hardcoded to run the menu and loadscreens at 800x600.

Iirc People have looked into disabling this hardcoded function and restoring it to the way it was in RA2 many times but no one has been successful at it.

The issue being that resizing totally breaks the fullscreen rendering.

If you're still having issues with the mouse, try disabling acceleration from your mouse software, and changing it only from Windows mouse settings?

As for the game speed, maybe try this in the .ini:

[Options]
GameSpeed=6
GameSpeed=3
GameSpeed=1

Where 6 is fastest and 3 is normal; 1 is probably lowest, haven't tested because I don't hate myself.

I still maintain that for YR multiplayer the CNCNET patch is probably the greatest thing since sliced bread, however for singleplayer stick to vanilla 1.001.

If all else fails then hit me up via PM - let's set up a troubleshooting chat.

Link to comment
Share on other sites

On 3/28/2019 at 12:22 AM, CmdrWeakness said:

Hey RC, I've done some tinkering around. Try the German patches, they're super easy to unpatch so it won't hurt to try.

For YR 1.001 the German patch seems to work fine for mouse issues - now the only problem that exists is with loading and videos, the only solid response is from this forum:

The issue being that resizing totally breaks the fullscreen rendering.

If you're still having issues with the mouse, try disabling acceleration from your mouse software, and changing it only from Windows mouse settings?

As for the game speed, maybe try this in the .ini:

[Options]
GameSpeed=6
GameSpeed=3
GameSpeed=1

Where 6 is fastest and 3 is normal; 1 is probably lowest, haven't tested because I don't hate myself.

I still maintain that for YR multiplayer the CNCNET patch is probably the greatest thing since sliced bread, however for singleplayer stick to vanilla 1.001.

If all else fails then hit me up via PM - let's set up a troubleshooting chat.

Thanks for the suggestion, I tried the patches from this website, I think it's the one you mentioned: http://www.stuffhost.de/files/cnc/ EDIT: I realised that the scroll lag in online multiplayer is caused by my recording software. However in single player campaign and skimirsh, even without recording turned on, the scroll is laggy, even after the patch.

Edited by RC1985
Link to comment
Share on other sites

So it's about the speed (sensitivity) of the cursor, right? I'm just asking this again cause you mentioned the ScrollDelay patch of TS which doesn't change the sensitivity, it changes how fast your map is scrolling around when you touch the border of the screen. 

The scroll rate of Red Alert 2 seems to be bound to the game speed, that's why it looks slow and sluggish on the campaign (it runs at 30 FPS, compared to 60 FPS that people use in online games). You can adjust the game speed the way fir3w0rx described by passing a command line to the game.

 

Now let's talk about the mouse sensitivity, if you set "fullscreen=true" in ddraw.ini you'll get what you wanted, a 4:3 res will be stretched to 16:9 (very ugly... DON'T), as a side-effect, your cursor sensitivity will now also match your windows screen res (aka adjmouse=true). There is no way to change this behavior in TS/RA2 unfortunately, adjmouse=true is always forced in TS/RA2 due to the way the games handle the cursor in the menus.

 

Solution: Set "fullscreen=false" again in ddraw.ini. Now to get rid of the black bars you'll have to open your graphic card driver settings and enable stretching in there. Done.

 

Alternative Solution: Since you seem to have a 16:9 monitor, why not play the game in a 16:9 resolution such as 1280x720?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...