Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Posted (edited)

I'm getting an error after modifying the 3tnk.shp: "warning open source shp builder 3.36 is unable to open this file" even if I rename the file I get the same error. What's the fix to this?

 

 

Untitled.jpg.59312dedfcac481b3d8e5f95a4b2f49b.jpg

UPDATE: seems that new RA1 type shp causes this.

UPDATE 2: I found the cause, using the ellipse tool seems to break theRA1 type .shp for some reason.

Edited by CnCRedAlertFan

Share this post


Link to post
Share on other sites

Um. There is no such thing as a "new RA1 type shp". The SHP format of C&C1 and RA1 is identical. SHP Builder has always had a tendency to corrupt C&C1-type SHP files, though...

Try using Engie File Converter?

 

Share this post


Link to post
Share on other sites
On 7/24/2019 at 9:41 AM, Nyerguds said:

Um. There is no such thing as a "new RA1 type shp". The SHP format of C&C1 and RA1 is identical. SHP Builder has always had a tendency to corrupt C&C1-type SHP files, though...

Try using Engie File Converter?

 

Ah didn't know that RA1/C&C1 used an alternative to SHP Builder.

Ok I tried it out and it's weird. It doesn't use the correct color, and the only colors i see available are: grayscale, heights and rainbow. Also it has no tools for editing.

Share this post


Link to post
Share on other sites

Well, it's not an editor. As the name clearly says, it's a file converter.

As for the colours... SHP files don't have colours. If you want colours, you just need to add them yourself.

It's not exactly hard. Open an image that has a 256-colour palette, click the "Save" button next to the greyed out "inbuilt palette" dropdown, open the dropdown with palettes and select the "Create new..." at the bottom, give a name, and save it.

Or just, y'know... drop a C&C palette into the program's folder. I got a set of editing palettes handy. Engie will read the ????conv.pal ones ;)

 

Mind you, you can just edit your file in SHP editor, save it as TS SHP, and use Engie to convert that to TD/RA1 SHP afterwards. That should work fine. Doesn't even matter if you can't view it in the correct colours; as I said, SHP doesn't save colours anyway.

Share this post


Link to post
Share on other sites
On 8/5/2019 at 2:06 PM, Nyerguds said:

Well, it's not an editor. As the name clearly says, it's a file converter.

As for the colours... SHP files don't have colours. If you want colours, you just need to add them yourself.

It's not exactly hard. Open an image that has a 256-colour palette, click the "Save" button next to the greyed out "inbuilt palette" dropdown, open the dropdown with palettes and select the "Create new..." at the bottom, give a name, and save it.

Or just, y'know... drop a C&C palette into the program's folder. I got a set of editing palettes handy. Engie will read the ????conv.pal ones ;)

 

Mind you, you can just edit your file in SHP editor, save it as TS SHP, and use Engie to convert that to TD/RA1 SHP afterwards. That should work fine. Doesn't even matter if you can't view it in the correct colours; as I said, SHP doesn't save colours anyway.

 

Umm i guess you didn't read the Update2 where I said that the Elipse tool was corrupting the file. Engie can't open the corrupted files. I assumed you were suggesting Engie as an alternative, despite the name, to the properties of editing. Also, I see no TD/RA1 SHP option when i select Save file...when selecting frame -1 I see TS Shape File and C&C1 Shape File.

I have have simply been doing my edits in SHP without using the Elipse tool and the file saves correctly.

Share this post


Link to post
Share on other sites
On 8/11/2019 at 9:38 AM, CnCRedAlertFan said:

Umm i guess you didn't read the Update2 where I said that the Elipse tool was corrupting the file.

No, you said the ellipse tool was breaking the RA1 type .shp. So I suggested using TS type shp in OS SHP Editor instead, and converting that to TD shp with Engie afterwards 😛

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/14/2019 at 4:53 AM, Nyerguds said:

No, you said the ellipse tool was breaking the RA1 type .shp. So I suggested using TS type shp in OS SHP Editor instead, and converting that to TD shp with Engie afterwards 😛

 

I was obviously talking about TD, what else would I mean? I don't see a way to save in TD in Engie. I have been tinkering around with SHP and found out that creating a new SHP file I can do anything (change palette, use tools, save in TS then in TD) and the file won't break. Meanwhile using the 3tnk.shp (heavy tank) the SHP file will corrupt if i do anything besides use the Draw tool or replace colors.

Update: I tried again editing 3tnk.shp, but this time i saved in TS first, after using tools etc., and then reopened and saved in TD as a new file 31tnk.shp , also after using tools and i got no issues! I then used tools etc. and saved in 3tnk.shp, tried various things and the file wasn't getting corrupted. This is so weird...I can't trust it.

Edited by CnCRedAlertFan

Share this post


Link to post
Share on other sites

Well, I never used OS SHP editor, really. Much easier to convert to sprite sheet and edit that in a normal editor.

Though, free editors that decently support paletted images are getting more rare every year -_-

Share this post


Link to post
Share on other sites

Hi

im new here

im researching dune2 

try to create new SHP or WSA 

what can i use to do this?

OS SHP editor says for dune2 format = wrong format..

XCC mixer works fine, but it cant create SHP or WSA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By CnCRedAlertFan
      How do I make a unit deploy like in RA2? I can't find an art.ini to tell the game which frames to use for deploy.
    • By Genio
      Hi,
       
      is there any possibility to make the AI build and use:
       
      1. Marine troops including ship yard
      2. Air troops (even if the human Player didnt build any air troops?
      3. Nuclear weapons?
       
      Thank you
    • By pizzahat
      Hey everyone.  I've been working on making the switch over to Manjaro and everything is great so far.  Unfortunately, I have been unable to get CNCnet working for Red Alert. I have tried the Manjaro package and the Windows package via Wine, and I have Wine mono and about as many other Wine packages that I can think of. I am running what is pretty much a fresh install of Manjaro XFCE on an AMD A8 based laptop with 8gb of RAM and plenty of space on the SSD. These are my two problems in more detail, I appreciate any advice or direction in advance:
      1. Manjaro Package Installer: Everything seems to process correctly up until the very end. The installer hangs at "Finishing Installation... Installing .NET framework 2.0" for about a minute then it just goes away and CNCnet will not open via the program shortcut. I've run the script at the bottom of my post a few times to retry the process, but no dice.
      2. Windows .exe installer via Wine. The installation goes on without a hitch, and Red Alert is able to open successfully.  Every time I pick the "Online" option, the application crashes without an error. I've tried selecting several different resolution and rendering options.
       
      rm -rf ~/.local/share/cncnet
    • By SVT_Mustang
      Hi guys,
      played this game for many years and have used the Cncnet client for RA1 for about 18-20 months. Recently purchased a new platform with Windows10. Same internet connection. Client loads okay but regularly I'm getting disconnected with the client showing "ping timeout". Internet settings have been re-booted, I don't have any firewall settings on at this present time but the problem persists. If I loads the client and go into the game lobby I have around a minute to get into a multiplayer game before none of my choices register with other players. Text, readying up etc etc.
      Some help would be greatly appreciated. I have removed the RA files a couple of times, tried most things but the same issue persists.
      When I do manage to get into a game, it lasts and for some reason I can hold out a game with no issues...….
       
      Many thanks,
       
    • By delly88
      Hello Everyone,
      Please can I get some help ?
      I have installed the full version of the above, from this website.
      I'm running Windows 10 home.
      Installation was fine, start up application, select play offline...
      Game starts but just the front screen then crashes.
      ctrl alt delete doesn't work, I have to restart computer.
       
      I had this game on Dosbox but for some reason it stopped loading new levels.
      So it may be an easy fix but I'm becoming easily exhausted of trying to get this game to run.
       
      Thanks in advance 😁
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...