Jump to content

Unable to run CnCNet Client for Red Alert 2


2bpencil
 Share

Recommended Posts

As per the mentioned topic, I was unable to run the CnCNet Client for Red Alert 2

I have installed Red Alert 2 and Yuri's Revenge via The First Decade DVD, followed by the CnCNet5_YR_Installer which I downloaded from cncnet.org.  Upon installation, I think the program tried to run as there was immediately a window popped up with the heading "Kabooooooom" indicating that Yuri's Revenge has crashed, and a crash log has been saved.  I closed the prompt and tried opening Yuri's Revenge CnCNet via its icon on the desktop as well as in its folder, and the same crashes happened with new crash reports created. 

I can still run Red Alert 2 when I tried opening it via its original Command & Conquer The First Decade icon.  It crashed several times and I managed to play a skirmish game without any crash once.

I have also tried uninstalling and reinstalling the CnCNet Client, however that didn't help.

Would appreciate if someone can kindly assist or advise the issues that I have.  I have attached the crash logs if that helps.

Thank you in advance.

ClientCrashLog_2022_05_03_21_36.txt ClientCrashLog_2022_05_03_21_42.txt

Link to comment
Share on other sites

Per the log file you uploaded, it appears the client is unable to render properly at your machine's native resolution. Please find the `ra2md.ini` file in your installation path and edit the ClientResolutionX and ClientResolutionY properties in the [Video] section. Set these values to something lower for the time being, simply to get the client to launch successfully. You can then change your client resolution from within the options in the client to something more suitable.

Example:

[Video]
ClientResolutionX=1920
ClientResolutionY=1080

 

Link to comment
Share on other sites

Thank you for your response.

I located the file you mentioned, ie ra2md.ini, however there wasn't any ClientResolutionX and ClientResolutionY. There was only:

[Video]
UseGraphicsPatch=Yes
AllowHiResModes=Yes
ScreenWidth=800
ScreenHeight=600
[Options]
Win8Compat=Yes
 

I tried changing the ScreenWidth to 1920 and ScreenHeight to 1080 instead. But the problem still persists.

RA2MD.ini

Link to comment
Share on other sites

In your installation folder, there should be a file called ra2md.ini. Can you please edit it and try adding/editing the following section and key? Then, try to start your client again.

[Compatibility]
Renderer=CNC_DDRAW

If that does not work, please try this renderer instead:

[Compatibility]
Renderer=TS_DDRAW

These are settings that can be edit IN the client, once you've gotten it to actually launch, but if you've gotten that far, you probably don't need to edit it anymore.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...