Jump to content
  • 0

Tiberian Sun Menu problem



Hi. So I'm using a Dell Inspiron 3520 and Windows 8, and ever since I've started trying to play Tiberian Sun, the menu sort of locks up. The game starts up normally and I'll reach the menu, but as soon as I click on any of the tabs (like "options," "skirmish," or "campaign"), the music just fades out and I get stuck at the menu until I press escape. None of the new screens, like the skirmish setup or game options, show up. After I press escape, I can click on the menu tabs again, but that just repeats the problem. The only thing I can really do right now is start up the game, look at the menu, and quit.


I've played the game before on other computers, and it's worked just fine. I've tried playing the game both through my copy of the First Decade and the copy from this site, but neither works, so I know it has to be something with my computer. I've tried running it as administrator and in compatibility modes, but those didn't work either.


I'd really appreciate it if someone could tell me how to fix this. (I've looked at other forum topic that sounded similar to this problem, but they were all different).


Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...