Jump to content

TS GDI Campaign Broken


lcronos
 Share

Recommended Posts

Hi, I am playing through the GDI campaign in the base game (specifically, the version that came in the Ultimate Edition). I installed the patch FunkyFr3sh posted here, along with the Tiberian Sun Enhanced mod. After beating the mission "Destroy Chemical Supply", I wind up getting a "Failed to initiate map selection" error and then get kicked all the way back to the first GDI mission. My first thought was that the TS Enhanced mod broke something, so I tried finishing the level from a copy of the game I made before I installed the mod (the other patch was still active since I can't play the game without it). Even without TS Enhanced, I get the same warning. I was loading a save from just before I beat the level when I tried without the mod (amazingly, it didn't crash), I haven't tried restarting the level.

I can skip the level and just play the next one and everything seems to work fine (I've actually beaten the next level at this point, just to see what would happen).

This issue happens whether I put Ghost Stalker on the train or not (so it isn't related to the hidden mission).

Has anyone ever encountered something like this before? The only results I see when I search for "Failed to initiate map selection" are all from modders trying to debug custom campaigns. I can keep playing the save I have, but I just don't like leaving bugs like this alone (it would suck if after beating this mission I get locked out of finishing the campaign because the issue came up again).

If it helps, I'm using Windows 10.

Link to comment
Share on other sites

Well I went ahead and restarted the mission, this time with the mod disabled when I hit restart and everything seems to have worked. It automatically put me in the next level. I'll try using the mod again now and see how things work. With any luck, that was the only bugged mission.

I guess I should have tried this before posting, but too late to worry about that now.

  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...