Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Ad1

Cannot get C&C Generals to work no matter what I try (Directx 8.1 error)

Recommended Posts

Right ok. So this is a baffling mystery. My laptop spec in short summary. Intel core i7 8th gen 8750H CPU, Gtx1060 6GB GPU, 16GB ram, Windows 10 pro (version 1903 AFAIK).

So I have the directx 8.1 error shown on so many Generals "fix" videos. Every way to "fix" it hast worked. Here is what I have tried.

1). The simple "delete the dgbhelp.dll files from both generals and zero hour folders, Still get directx error.

2). Tried the simple "change the resolution" fix on the options/ini file, still get directx error

3). Tried to wrap the dll using DGvoodoo2 dll wrapper (this was a suggestion made by a forum post which got the poster's generals to work) and paste it into the generals directory, then copy 4 dll files from the dgvoodoo x86 folder into the main generals directory, and rename d3d8.dll file to d3d8x.dll. still get the directx error.

4). suggested to me by "Generals legionnaire", double checked that the generals data and generals zero hour data files (which appear by default, and are supposed to do so, in your documents folder) aren't accidentally being placed in microsoft one drive. (I checked, and my one drive wasn't even set up). Also to check in the registry editor that the reg's for the game contain the right information. All was as it should. Still get directx error.

5). Downloaded and installed the official microsoft directx redistribution files, which will replace any missing old directx data which is supposed to be present on directx 12 which might not be. Still get the directx error

6). Probably the most baffling, and one I was CERTAIN, HAD to work. Tried the brilliant "Gen patcher" created by "generals legionnaire". This is a great custom made program which goes through all your generals/generalsZH directory files and corrects every potential issue which is known to cause this directx error, fixes resolution issue and much more. STILL get the directx error ....

Just to add. The Generals version I am using is the Origin ultimate collection one. But I have tried it from Oldgamesdownload.com just to be sure it wasn't my version at fault. Also, before trying each step I first uninstalled and reinstalled a fresh, unchanged install of the game, to eliminate any chance of contamination and/or changes contradicting changes. I have also tried all the "fixes" mentioned above together at the same time. STILL get the directx error. I really don't know how it can still not be working. Is there anything more at all I can try? Anyone on youtube or anywhere else found another way to get the game to work? Or, having replayed all the C&C games again, bar Generals, am I just going to have to accept the fact this one isn't ever gonna work for me, and just cut my losses and give up?

Share this post


Link to post
Share on other sites

Just to let you know, I solved this issue. I needed to paste the d3d8.dll file from dgvoodoo2 "MS" folder into the directory with the generals exe. It worked then. I had an issue with it crashing every time I alt-tabbed out, but, once we knew what was needed to get it to run, I got sent a different d3d8.dll file from legionnaire generals. After replacing the old dll with the new it worked flawlessly. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...