Jump to content
  • 0

RA2 from ultimate collection not working, win10



Hello all,

I'm sure that this has been asked, but I am not finding any information that's been able to help.

I have the Command&Conquer Ultimate Collection that worked just fine on both windows 7 and windows 8. However, when I've tried to run the game on windows 10 I can't get it to work.

The game will start, I can hear all the audio and the menu load, and I can even click on things in the menu, but I cannot see anything. All I get is a black screen. I've tried the graphics patch, I've tried running everything in compatibility mode, and I've tried running everything as an administrator. Can you guys please help?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...