Jump to content

Moddified game keeps crashing


Recommended Posts

Hello everyone,
like the title already suggests, I have a problem with my Tiberian Sun installation. But first of all, I am german and not an english native speaker so pls excuse my grammar.

My problem: After a long time I decided to reinstall and play TS once again. So I installed TFD (german version), downloaded the TSPatch and started the game. Everything worked perfect so far but I didn't just want to play the standard game, I want to play singleplayer with mods and modified maps. So I copied a mod called Tiberian Sun Retro by SMIFFGIG into the game folder and tried to play the game. Well it works sometimes, but not all the time, I am trying to describe the problem as good, as I can in the hope someone can help.

The game crashes when I try to start a skirmish game at the initialization screen (with the GDI titan screen or the Nod ICBM). The weird thing is, sometimes the skirmish game starts normally and sometimes it straight crashes. I tried different maps and it seems like, the larger the map and the more it has been modified, the more likely it is, that the game crashes. For example the smaller standard maps work, but the larger maps with many objects won't. Similar goes for AI, when I select one AI opponent with random color, side and start point, it sometimes work. If I select more opponents with a given color and startpoint, the game will most likely crash even on standard maps.

What I already tried:

  • Download TS from CNCnet
  • Reinstall TFD
  • Deactivate antivirus and checked security settings
  • Tried every single renderer
  • Changed to low resolutions
  • Did the mod entry in cncnet5.ini (CustomGameName=Retro; CustomGameType=tsr)

My PC:
CPU: AMD Ryzen 7 1800X
RAM: 32GB Dual Rank @3200MHz
Motherboard: Asus ROG Strix X370-F Gaming
GPU: Asus Strix GTX 1080Ti
OS: Windows 10 x64 Education

I also discoverd, that the game will run fine, if I play with the standard rules.ini. I can even let all the other modified mix files in the game folder, the game wont't crash, but as soon, as I replace the rules.ini file, the keep getting the described crashes. Of course I have attached the except file to this post. Did I miss something so that mods are generally playable with cncnet?

I really hope someone can help me. I played Tiberian Sun Retro earlier the days with Hyperpatch and never had any problems except for some random crashes but not frequently. This is my first try to play TS with cncnet and I want to get it to work. I really hope someone will bother dealing with my problem and try to help me solving it.





Link to comment
Share on other sites

Found it! I made several mistakes in the mod itself e.g. files named incorectly in the mix archive, wrong entries in rules.ini and a couple other small mistakes. It was a little tough finding all the mismatches but now everything works :)

Thread can be closed

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...