Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
AManWearingAHat

Problem playing the campaign

Recommended Posts

As a child this was one of my favorite games, and I was quite depressed to see Windows 7 couldn't run it off my first decade disk. Then I found this wonderful place and I can live my childhood memories all over again. Alas I have run into some issues.

 

Ive played through a couple skirmishes no problems, when I try the campaigns though I hit an issue. I haven't tried the allied side yet. The videos work fine, the music is good, the first soviet mission plays smoothly with all the videos. How ever when I get to the map screen to select the next mission, I pick the mission and the game crashes with this error.

 

"The instruction at 005d747d referenced memory at 00000001

The memory could not be read from

 

Click on OK to terminate the application"

 

I'm quite familiar with virtual clone drive, and I mounted a dummy .iso as advised. Still no luck.

 

If its worth anything I'm running Windows 7 64 bit on an Intel Core i5 @3.30 gHz

Share this post


Link to post
Share on other sites

...I'm assuming you're talking about Red Alert 1? Because, you kinda didn't mention it, at all.

 

Also, there's no reason why it shouldn't work from TFD, as long as you apply a few patches, and both install and run the games as administrator, and make sure your user is the actual owner of the TFD files.

Share this post


Link to post
Share on other sites

Yes I am talking about Red Alert 1, sorry for not being clear.

 

I have tried installing TFD in its entirety, but when I do I get an error during the installation. The only games it allows me to install are Generals and RA2 and Yuris Revenge without error.

Share this post


Link to post
Share on other sites

Hm, the basics, then.

-Is your DVD player recent? Some old ones might not be able to read dual-layered DVDs.

-Are you installing as administrator? That means, right click on the installer, selecting Run As Administrator.

Share this post


Link to post
Share on other sites

Did the TFD install, installed both RA patches and the C&C patch from that site you linked me.

 

Still getting the same error when I try and advance to the next mission in the soviet campaign. I am running as administrator

 

Installed

 

-Nyerguds' Red Alert main.mix cleanup

-C&C95 patch 1.06:

-RA95 patch 3.03:

Share this post


Link to post
Share on other sites

That's... worrying. I'm looking into RA95 right now to see what that error address is. Was the address value (005d747d) the same after the full reinstall?

 

---

 

Okay, this is scary. I traced the error back to part of the basic printf_ functions set. This deals with, um, pretty much all basic text formatting operations. I could understand getting that if you used any kind of mod or something which could modify the strings file, but if both are a 100% clean installs with just those patches, I don't see how this could happen.

 

You didn't install RA-Ed into the folder or anything, did you? Because I got an all-files-included version of it that should most definitely NEVER be put into the game folder, since it uses stripped mixfiles that only contain the files RA-Ed uses.

 

 

You may want to try if CnC-DDraw helps; it has an option to make sure the game runs on a single CPU core.

Share this post


Link to post
Share on other sites

The only additional things I installed are what I listed. I will do a completely clean install of TFD. Install the same mods and see what results I get. If I end up with the same error I'll try the single core option. Either way I'll report back with results later tonight. Thank you for the help, I greatly appreciate it.

 

 

 

This is the error Im getting currently

Error.png

Share this post


Link to post
Share on other sites

fresh install with all the patches installed and its functional. that was weird...

 

Well almost functional.... now we have a new wonderful error to play with. This one occurs on the Soviet Spy mission right as the intel center is blowing up and he flees the compound.

 

The instruction at 005ab38e referenced memory at 0d2192e4

The memory could not be read from

 

 

http://gyazo.com/88452ade4c4d1bda22120e067b0219bb

 

Why me??

Share this post


Link to post
Share on other sites

If you're on a dual or quad core machine, your issue could be due to core desynchronization.

 

Did you try using CnC-DDraw? If it is core desync, that should fix it. Do read the documentation on the site, though; the standard running behaviour of cnc-ddraw puts the game in windowed mode :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...