Jump to content

TSinstaller fails at downloading dotnefx.exe.


Junglized
 Share

Recommended Posts

As in the title, I'm trying to install Tiberium Sun but it fails to download dotnetfx.exe with 404 error. That unfortunately makes the whole installation process to fail. Is there workaround to this? Any help would be much appreciated.

PS: It worked just find around a month or so ago.


2084226136_Screenshotfrom2021-08-2910-13-15.png.338c8c7751ad1ff28e9227225e1525fa.png


1800069966_Zrzutekranuz2021-08-2910-10-54.png.25e7bb4134391971d2bc53339995a567.png

Edited by Junglized
Link to comment
Share on other sites

I got the same issue, so I ran a packet capture and found the URL that the installer is looking for:

http://download.microsoft.com/download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe

 

This URL must have been moved. The file appears to be this one:

https://www.virustotal.com/gui/file/46693d9b74d12454d117cc61ff2e9481cabb100b4d74eb5367d3cf88b89a0e71/details

 

I think this file is not used. The workaround is to create a local HTTP server that will serve the file (or any file with the filename dotnetfx.exe). Then set an entry for "download.microsoft.com" in your /etc/hosts.

 

You can do this easily with a few shell commands:

 

# append the following line to your /etc/hosts file, but use your own LAN IP address 
# download.microsoft.com	192.168.0.9 

# create the expected directory path
mkdir -p download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/

# create an empty file that the installer is looking for
touch download/5/6/7/567758a3-759e-473e-bf8f-52154438565a/dotnetfx.exe

# run an HTTP server (must be root to bind to port 80)
sudo python3 -m http.server 80

 

With this workaround I was able to install and run Tiberian Sun.

Link to comment
Share on other sites

Microsoft seems to have removed the .NET Framework version 2.0 from their servers. I'll update the installer with a new link when I get the time. Or simply remove it as it is only really neccessary for Windows Vista and older if I remember correctly.

In the mean time if someone needs .NET Framework 2.0 it seems to be still available from Lenovo's site:

https://support.lenovo.com/us/en/downloads/ds002897-microsoft-net-framework-version-20-for-windows-2000-xp-desktops-notebooks

Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...