Jump to content

Yuri's Revenge not loading on Windows 10 either via CNC Net Launcher or via native install


Recommended Posts

Evening all,

Hoping for some help.  I've installed Red Alert 2, using the Windows 10 work around - as I had the original discs.  Yuri's Revenge somehow managed to install via the original disc that I had (dunno if that's the issue to be honest?).

When launching Yuri's Revenge via the native shortcut (GameMD.exe), I get a black screen with a cursor for about 3mins, then it dumps me back to the Windows Desktop.  When trying to launch the campaign through CNC Net - it just doesn't respond.  

I've tried the following:

Command & Conquer Graphics Patcher (stuffhost.de)

and DDWrapper

All to no avail.  The Red Alert 2 campaign launches fine and i've had no issues with it, same with the Skirmish Mode, that runs fine and including Yuri as an opponent or playing as them.  Just very, very stuck.

Hoping some geniuses on here can help!

Screenshot 2023-06-17 155452.png

Screenshot 2023-06-17 160611.png

Screenshot 2023-06-17 160723.png

Screenshot 2023-06-17 160805.png

Screenshot 2023-06-17 202806.png

Screenshot 2023-06-17 202851.png

Screenshot 2023-06-17 202943.png

Screenshot 2023-06-17 203035.png

Screenshot 2023-06-17 203124.png

Screenshot 2023-06-17 203224.png

Screenshot 2023-06-17 203338.png

Link to comment
Share on other sites

Hi, if you already installed the whole game and the CnCNet you shouldn't need external patches as CnCNet fixes all the problems in the .ini files and gives an updated graphics renderer.

I would try using ra2.exe and ra2md.exe instead of game.exe and gamemd.exe. Create a shortcut for them and set the compatibility settings to winxp sp3 as known and run as admin, and see what happens.


Edited by XMaDTanKX aka T-90
Link to comment
Share on other sites

  • 5 months later...

I have the exact same problem as OP. Essentially, RA2 runs fine, but YR will not run at all. Same symptoms as OP.

Here's the steps I took to install RA2+YR on Windows 10 using the original CDs that I purchased new back in the day, along with the resulting behavior:

note: these steps were performed in this exact order

# Red Alert 2 installation

  1. Installed XWIS Red Alert 2 multiplayer-only edition (aka RA2 MP) from https://xwis.net/forums/index.php/topic/177134-downloads/
  2. Copied the following files from the original Red Alert 2 game discs into the same directory the RA2 MP edition above was installed into:
    • ALLIED disc: `maps01.mix`, `movies01.mix`, `multi.mix`, `theme.mix` (will require overwrite)
    • SOVIET disc: `maps02.mix`, `movies02.mix` (no overwrite needed)
  3. Once installed into the game directory, set properties of `game.exe` and `ra2.exe` to "Run as Administrator" and set compatibility mode for "Windows XP SP2" (also tried SP3 and Windows 7)

# Yuri's Revenge installation

  1. Ran the installer from the original Yuri's Revenge game disc (requires CD key) and pointed to the same installation directory as used above (the installer was smart enough to identify the installation directory - I did not have to manually select it, although I did sanity check it was correct)
  2. During installation, deselected all items except for the main YR game (i.e. no Westwood online components)
  3. Once installed into the game directory, set properties of `gamemd.exe` and `RA2MD.exe` to "Run as Administrator" and set compatibility mode for "Windows XP SP2" (also tried SP3 and Windows 7, and also tried disabling compat mode and deselecting admin entirely)

# Post-installation patching

  1. Downloaded the CnCNet Client from https://cncnet.org/yuris-revenge#download into a different directory from the game installation
  2. Ran the CnCNet Client installer and pointed to the same game installation directory as used above
  3. Once installed into the game directory, set properties of `CnCNetYRLauncher.exe` to "Run as Administrator" and set compatibility mode for "Windows 7"
  4. Ran `CnCNetYRLauncher.exe` within the RA2 installation directory and it prompted to update the launcher
    1. This is where I started running into problems. First, the launcher died midway through patching and Windows complained about a missing .NET 3.5 runtime but thankfully prompted to installed it. Okay, fine, installed.
    2. Upon re-running the launcher, it quickly begins "glossing over" and then "soft locking" - first, on-hover mouse effects for buttons stop working, then on-hover sound effects for buttons stop working, then the buttons themselves stop working, rendering the entire launcher completely unresponsive although the music continues to play. Only way out at this point is to ALT+F4.
    3. After repeated attempts of running the launcher and then killing it due to unresponsiveness, I was able to memorize the menus and quickly go in to tweak a few settings such as resolution and renderer, which did end up getting written to the corresponding `RA2.INI` and `RA2MD.ini` configuration files successfully (confirmed via Notepad).

# Running the games

## Red Alert 2

At this point, firing up RA2 via `game.exe` or `ra2.exe` works as expected: RA2 Westwood static splash screen appears immediately (no sound), then Westwood animated logo screen appears shortly after (with sound), then the classic RA2 menu appears (with sound) - all displayed in the desired resolution configured within the CnCNet Launcher.

However, firing up `RA2 Campaign` from the CnCNet Launcher is laughable. It "works" in the sense that RA2 fires up successfully, but the CnCNet Launcher continues to run and continues to blast its own music, overlapping RA2's music. Obviously, this is not a usable method.

## Yuri's Revenge

As the OP states, Yuri's Revenge does not run at all. Not from a functional perspective, at least.

Firing up YR via `gamemd.exe` does not work, nothing happens. But using `RA2MD.exe` results in a low-res blank screen (not at the resolution I set via the CnCNet Launcher, but probably the game's original default resolution) followed by a white old-school Windows mouse cursor, but that's it. At this point, the only way out is to WIN+TAB -> New Desktop -> select it -> CTRL+SHIFT+ESC (hotkey to bring up Task Manager directly) or CTRL+ALT+DEL -> Task Manager and then kill the "Main executable for Yuri's Revenge - Not responding".

# Observations

  • Messing with the "Run as Administrator" and "Compatibility Mode" settings didn't seem to make a difference. I've found these options rarely make a difference anyway. Sometimes they do work for certain games, but in my experience these methods are not reliable and more of a "throw it at the wall and see what sticks" type of solution.
  • Trying different renderers didn't make a difference. Same behavior; RA2 works fine, YR is completely borked. I did confirm each time the desired setting was written to the INIs successfully.
  • Interestingly, comparing OP's game-directory screenshots to my own, I've found that I do not have: `mapsmd03.mix`, `movmd03.mix` but do have `Red Alert 2.exe` which the OP doesn't.

So, it seems all of these various installation and patching methods result in inconsistent files after the fact. No wonder it's so difficult to duplicate a working installation.

Interestingly, I did have a working installation of RA2+YR on Windows 10 a few years back, although I can't recall what exact steps I took to set that up. Since then, that particular installation no longer works (had to re-install OS since then, so it's likely Windows drivers or other dependent DLLs have changed - I don't keep my game files on my OS drive, so the game files were untouched but the OS was completely fresh-installed). I'm going to try to pin down what I did for that original installation and if I can get it working again from scratch, I'll post a detailed follow-up with the steps.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...