Jump to content
  • 1

[solved] Yuri's Revenge & wine & linux?


G.I.
 Share

Question

Updated:

So I got it to work.

You may not try to use any version below 1.7.38. For example 1.7.1X don't work at all, you will get "KABOOM" style error.

 

ODkldhE.png?1

 

How to get it to work with wine:

WINEARCH=win32 WINEPREFIX=$HOME/wine/prefix/ilovera2 winecfg # setup your wine prefix however you like first.
WINEPREFIX=$HOME/wine/prefix/ilovera2 winetricks dotnet35
WINEPREFIX=$HOME/wine/prefix/ilovera2 winetricks vcrun2008 dotnet20sp2 # this bit is important, winetricks does not install sp2 automatically, but client needs this to work!

 

Now launch your client:

cd ~/wine/Games/Red\ Alert\ 2; WINEDEBUG=-all WINEPREFIX=$HOME/wine/prefix/ilovera2 wine CnCNetYRLauncher.exe

 

If you need to install client, get it first here:

WINEDEBUG=-all WINEPREFIX=$HOME/wine/prefix/ilovera2 wine CnCNet5_YR_Installer.exe

 

To play Yuri's Revenge with wine you also need to set ddraw and wsock32 to native in winecfg. (this tidbit is from winehq)

In case your game runs slow, save this as something.reg and import it into your prefix using regedit:

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"DirectDrawRenderer"="opengl"

 

Current problems:

  • As you can see on screenshot (look for "Game Information") text is sort of smeared or blurred, or outright painted over with something. I have no idea why wine does this, while crossover does not. As it is I'm looking for a way to fix it.
  • Some options are sometimes impossible to change, because of previous issue, thank devs there is "Ready" button when you join somebody's game.

Thankfully most of things have tooltips though, so if you can't read something, hover your mouse over and read the tooltip.

All in all, it's fine to say that you can play RA2 just fine on linux using wine. (provided you have dotnet35 and dotnet20sp2 installed)

 


Original message:

Hey guys!

What's the status on this? I tried getting latest wine version available with CncNet5 client for RA2/YR (and dotnet installed).

It sort of installs/launches and crashes right away when it tries to self-update (my best educated guess).

 

25. 10. 19:45:28.168    ***Logfile for Yuri's Revenge client***
25. 10. 19:45:28.182    Client version: 1.15.2.9
25. 10. 19:45:28.198    Initializing settings.
25. 10. 19:45:28.263    Initializing updater.
25. 10. 19:45:28.265    An unhandled exception has occured. Info:
25. 10. 19:45:28.265    Message: Could not load file or assembly 'ClientCore, Version=1.15.2.6, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Bad format.
25. 10. 19:45:28.268    Source: DTAUpdater
25. 10. 19:45:28.269    TargetSite.Name: Initialize
25. 10. 19:45:28.273    Stacktrace:    at Updater.CUpdater.Initialize()
   at <U+200D><U+206B><U+200C><U+200D><U+206E><U+206B><U+206E><U+200C><U+202A><U+202E><U+202D><U+206A><U+206D><U+202B><U+202C><U+202D><U+200C><U+200E><U+206A><U+206B><U+202E><U+206E><U+200D><U+202A><U+200F><U+200D><U+202B><U+200D>
<U+202E><U+202A><U+200B><U+206A><U+206D><U+200D><U+206B><U+206F><U+206C><U+200C><U+200D><U+202E>.<U+202A><U+200D><U+202A><U+200C><U+200F><U+206D><U+206A><U+206F><U+202D><U+202A><U+206B><U+202B><U+200C><U+200D><U+206D><U+200B><U+200C>
<U+200B><U+202B><U+200B><U+202C><U+200C><U+200E><U+202A><U+206A><U+202B><U+200F><U+206A><U+202E><U+200B><U+200B><U+206C><U+200C><U+200D><U+200B><U+200F><U+202E><U+202C><U+206E><U+202E>()
   at <U+206B><U+202E><U+200E><U+202C><U+200E><U+206B><U+206E><U+202C><U+206C><U+200C><U+200D><U+200C><U+206A><U+200C><U+200F><U+200C><U+206C><U+202A><U+200E><U+206E><U+200D><U+206C><U+206A><U+200B><U+200C><U+200F><U+206C><U+200E>
<U+202D><U+206A><U+206D><U+202D><U+200E><U+200D><U+200B><U+200B><U+206D><U+202C><U+202E>.<U+200B><U+206D><U+202D><U+200D><U+202C><U+200B><U+200E><U+202D><U+206B><U+206D><U+206B><U+200F><U+200E><U+202C><U+200E><U+202E><U+200F><U+202D>
<U+200B><U+200B><U+202E><U+202D><U+200D><U+200F><U+206B><U+200D><U+206F><U+206B><U+200D><U+206F><U+200D><U+206A><U+202E><U+206F><U+200C><U+200D><U+202B><U+206E><U+202A><U+202E>(String[] )
   at <U+202A><U+206C><U+200B><U+206B><U+200B><U+206F><U+206A><U+206C><U+200B><U+200D><U+200B><U+200B><U+200E><U+200C><U+202B><U+206B><U+202D><U+200D><U+206E><U+202C><U+202D><U+202C><U+206A><U+200C><U+206C><U+206E><U+206F><U+206B>
<U+200F><U+202C><U+200C><U+206A><U+202C><U+206E><U+202B><U+206F><U+206E><U+202A><U+200C><U+202E>.<U+206A><U+200E><U+202E><U+200F><U+206C><U+202C><U+200B><U+200F><U+202C><U+200E><U+206D><U+200D><U+206C><U+202D><U+202E><U+200B><U+202E>
<U+202E><U+202B><U+202D><U+200E><U+206E><U+202B><U+200F><U+202A><U+206C><U+206C><U+206E><U+200C><U+206E><U+206B><U+202D><U+200E><U+206B><U+200E><U+206A><U+206D><U+206A><U+202A><U+202E>(String[] )

 

Does anyone even play this epic sequel online using wine on linux or it's a pipe dream at the moment?

Thanks for any answer.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Dotnet 3.5 actually sort of supported by wine. I simply ran "winetricks dotnet35" command and had installed 2.0, 2.0sp1, 3.0, 3.0sp1 and 3.5 successfully.

 

Well, might as well try different wine versions. I only tried 1.7.53 and 1.7.38 so far.

 

Also I thought client used dotnet 2.0 specifically, it's 3.5 now?

Link to comment
Share on other sites

  • 0

Yeah with wine I'm only getting nothing but:

Unhandled Exception: System.BadImageFormatException: Could not load file or assembly 'ClientCore, Version=1.15.2.6, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Bad format.
File name: 'ClientCore, Version=1.15.2.6, Culture=neutral, PublicKeyToken=null' ---> System.BadImageFormatException: Bad format. (Exception from HRESULT: 0x8007000B)
   at Updater.CUpdater.Initialize()

I'm trying on 64bit linux, but on 32bit wine prefix (because there is no 64bit dotnet support beyond 2.0 currently if I'm not mistaken). No idea if that error actually means there is something wrong with client and 32-bit / 64-bit conflict or something else (google isn't overly helpful beyond that). Kinda shame.

 

Well thanks for answering my questions anyway. Guess I'll try trial crossover one of these days.

Link to comment
Share on other sites

  • 0

I can confirm client works with crossover on linux (my distro is Archlinux 64bit). Albeit I didn't play yet. (click image to enlarge)

 

ZCSFDOQ.png?1

 

Still. I'm interested in getting this working under wine. Since crossover, as you all know, is shareware application, even though trial is available. I'll try tinkering with a few more things using wine.

 

Edit:

I don't think wine has a stable enough for NET 3.5

Who knew? It actually works on wine, too. Now how did I do this I have no idea. Stay tuned, while I figure out exactly how I pulled this of.

 

ODkldhE.png?1

 

Edit2: updated first post.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...