Jump to content
  • 0

Soft lock on launch


Playergh
 Share

Question

So I just installed D2K on my computer, and I'm feeling pretty stoked to start playing. I launched a skirmish match against some bots and it was fun. So I thought "Why not try the campaign?". Only problem is, I go to the launcher, press "Launch Campaign", the intro plays, and the game doesn't progress any further. It stays on a black screen, and I can't alt-tab out of it to end the task with task manager.

 

These are my video settings:

 

Video BackBuffer [ ]

Show FPS [X]

Single Processor Affinity [X]

Disable Max Windowed Mode [X]

Use Improved FPS Limiter [X]

Force DirectDraw Emulation [ ]

Cutscene Change Resolution [ ]

Disable High DPI Scaling [ ]

Resolution: 1024x768

Bits Per Pixel: 16

 

Does anyone know what the problem might be? Thanks in advance. :d2k:

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

So I just installed D2K on my computer, and I'm feeling pretty stoked to start playing. I launched a skirmish match against some bots and it was fun. So I thought "Why not try the campaign?". Only problem is, I go to the launcher, press "Launch Campaign", the intro plays, and the game doesn't progress any further. It stays on a black screen, and I can't alt-tab out of it to end the task with task manager.

 

These are my video settings:

 

Video BackBuffer [ ]

Show FPS [X]

Single Processor Affinity [X]

Disable Max Windowed Mode [X]

Use Improved FPS Limiter [X]

Force DirectDraw Emulation [ ]

Cutscene Change Resolution [ ]

Disable High DPI Scaling [ ]

Resolution: 1024x768

Bits Per Pixel: 16

 

Does anyone know what the problem might be? Thanks in advance. :d2k:

 

Try to enable Dxwnd + GDI Mode to see if that makes any difference. Window mode might be an option too if it still doesn't work

Link to comment
Share on other sites

  • 0

So I just installed D2K on my computer, and I'm feeling pretty stoked to start playing. I launched a skirmish match against some bots and it was fun. So I thought "Why not try the campaign?". Only problem is, I go to the launcher, press "Launch Campaign", the intro plays, and the game doesn't progress any further. It stays on a black screen, and I can't alt-tab out of it to end the task with task manager.

 

These are my video settings:

 

Video BackBuffer [ ]

Show FPS [X]

Single Processor Affinity [X]

Disable Max Windowed Mode [X]

Use Improved FPS Limiter [X]

Force DirectDraw Emulation [ ]

Cutscene Change Resolution [ ]

Disable High DPI Scaling [ ]

Resolution: 1024x768

Bits Per Pixel: 16

 

Does anyone know what the problem might be? Thanks in advance. :d2k:

 

Try to enable Dxwnd + GDI Mode to see if that makes any difference. Window mode might be an option too if it still doesn't work

 

GDI Mode is already on. The problem isn't exactly that I can't alt-tab. It's more that when I do alt-tab, the black screen of the game overpowers the desktop, so I can't go to the task manager to close the program. But I'll definitely try windowed mode.

 

EDIT: Windowed mode got tried, and it failed. The exact same issue appeared, and the desktop got REALLY weird. The Dune 2000 application itself seemed to flicker in and out of existence at times, and the big black box was staring me right in the face, still overpowering everything else on the screen.

Link to comment
Share on other sites

  • 0

Just noticed you have videobackbuffer disabled, any reason for that? What operation system do you have?

I'm using Winows 8.1. The options menu mentioned that I might get some better performance if I turn it off, which is very appealing to me as I have a very bad computer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...