Jump to content
  • 0

[SOLVED] How to play online with a friend with a mod



First off, I have read the following topic: https://forums.cncnet.org/index.php?topic=6217.0


I tried it with a friend through LAN even on two different computers. We wanted to try the VSAI mod, which consists simply of rulesmd.ini and aimd.ini.

On both computers I had renamed spawner.xdp to spawnerX.xdp to disable it and renamed the VSAI rulesmd.ini to spawner.xdp.

The aimd.ini file I left untouched.


Now when I play a Skirmish map on one computer, there is no issue and the AI is correctly upgraded brutally and I can play fine through the CnCNet client.

When we try a LAN or Online game with one of the computers as a host and no other players, it does not work. We tried to start a simple game on Russian Roulette against one HARD AI to get it to work. When the host starts the game, both computers start loading. Though on both screens you only see yourself loading and the other one seems to have disconnected eventually. Both clients then proceed with a different session of the same map, so there is now effectively two clients with a 1v1 against the same AI.


The reason I have not changed the value to modmode=true, is because I could not find the INI file which was mentioned in that topic. I have opened ALL INI files in the RA2 directory AND its subdirectories and searched for modmode with notepad++ on all opened files. It did not return a hit.


Has this been changed since then?

How can I get this to work?

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0



I started from scratch took the following steps on both computers:

1. Re-downloaded VSAI

2. Renamed spawner.xdp to spawnerX.xdp in the RA2 dir to disable it

3. Extracted VSAI files (aimd.ini and rulesmd.ini) in the RA2 dir

4. Renamed rulesmd.ini to spawner.xdp


And.. it works!


Seems there was one byte difference in the rulesmd file on the two computers, which was causing this. I remember making more money available through rulesmd.ini when I played without the CNCNet client, since it was max 10000. This did not matter of course with the CNCNet client, but the difference did cause the error.


And for anyone that's interested: I did not enable modmode=yes anywhere, so that's not needed anymore it seems!


ps: I edited the subject to notify it's solved

Link to comment
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...