Jump to content
  • 0

cncnet and Windows 8.1


SuperSludge
 Share

Question

Hi there,

 

Is anyone able to play via cncnet on a SurfacePro 3 with windows 8.1? I have some troubles...

 

I recently bought red alert 2 (again) ;-) I've got it over origins.com with the ultimate all in one 17 c&c games bundle... the main reason is of course playing the game online, and thanks to cncnet it is still possible nowadays. Or at least it should...

 

I can start and play the game (skirmish) from the "normal" start (Ra2Launcher.exe) and the built in menus. However I want to play online...

 

When I start it via the cncnet client, it seems that the graphic settings get f***ed up somhow. I attached a screenshot. The screen seems to be truncated. And when the game is started no menus occur. Of course I can place my base but I'm not able to build anything ;-)

 

I played with the settings in the client a lot but I am just not able to get it fixed...

 

Also encountered that the ddraw.dll is added to the installation folder and the RA2MD.ini is changed on each start. Maybe it's possible to prevent these changes? I already tried to make the ini file readonly but this doesn't work.

 

I'm quite capable of programming (it's my profession) so a fork of the code to play around would also be a solution for me.

 

Thank you in advance

SuperSludge

 

PS: have a good start in to 2016

 

2015-12-31_15_12_48-Greenshot.png.d56e40937c5cfebad735efbb6f9879c0.png

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi Grant,

 

thank you for your incredible fast reply. Appreciate it.

 

I've deleted the file as suggested (also tried it before). And changed the resolution to almost every possible setting. Also tried 2 different external screens (they have different native resolutions by the way) with the same result: still truncated. I strongly suspect ddraw.dll

Link to comment
Share on other sites

  • 0

This looks like an issue related to display scaling. Go to the RA folder find ra95.exe, right click on it, click on "properties", go to the "compatibility tab" and enable "Disable display scaling on high DPI settings", do the same with ra95-spawn.exe.

 

For YR it is the same but with gamemd.exe, game.exe, ra2.exe, yuri.exe and gamemd-spawn.exe.

 

Alternatively you can disable scaling globally.

https://support.microsoft.com/en-us/kb/2900023

Link to comment
Share on other sites

  • 0

Hi Grant,

 

thank you for your incredible fast reply. Appreciate it.

 

I've deleted the file as suggested (also tried it before). And changed the resolution to almost every possible setting. Also tried 2 different external screens (they have different native resolutions by the way) with the same result: still truncated. I strongly suspect ddraw.dll

Hi - hmm if its anything to do with ts-ddraw, you can disable that in the display > render settings within the client options. Just change that to default, or IE-DDRAW and try again?

 

Ah maybe try Tore's reply first ^

Link to comment
Share on other sites

  • 0

Thanks Guys!

 

I actually got it working! The solution was changing "size of elements" setting (Windows) from normal to smaller (100%). I attached a screenshot unfurtonatly in german but maybe it helps someone anyway. I had that problem before in other applications but without your help I would be lost ;-)

 

Many thanks again and happy new year. See in the game ;-)

SuperSludge

 

EDIT

I just read the entire post of tore (RTFM) problem. I tried both solutionns and both of them solve the problem. :laugh:

2015-12-31_17_17_11-Systemsteuerung_Alle_Systemsteuerungselemente_Anzeige.png.0f7ed6910109fa9b82341cff3ece8258.png

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...