Jump to content
  • 0

Can't run C&C95 or RA1 (TFD versions) on Windows 7 (64bit)


Jonttu
 Share

Question

Hello, I'm new here... I'd love to get C&C 95 and RA1 to work on a new computer that's 100% mine.

 

Well... I have Windows 7 (64 bit) on it and these two games won't run.

I have them on The First Decade pack, and along with them I installed Tiberian Sun & Firestorm and Red Alert 2 without the exp.

I can play Red Alert 2 and Tiberian Sun but I can't play Tiberian Dawn or Red Alert (1).

I have installed them all into the Program Files (x86) folder this time (though the problem persists), I have patched TFD with the TFD 1.03 patch rev4 ignoring Trojan Horse alarms and I have also patched Tiberian Dawn to 1.06b rev2. I also have administrator mode enabled for both TFD, C&C95, (CnCnet) and RA1 shortcuts. But nothing seems to help...

I have also tried to some other measures but with no luck.

 

Ok so what happens when I try to launch the games.. Well not much.

I launch the game and it starts loading but then it stops. And thus the game won't launch at all. At best the screen has gone black then come back to the desktop with the C&C colours(?) then go black again and then ctd back..

 

The games did play well on another computer which has Windows XP. Not on mine as I have Win 7 64bit...

 

Can you help me?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Weird, I have Windows 7 64-bit and all C&C games works perfectly for me.

 

Try updating DirectX to the latest version. Also try updating the graphics card driver for your computer.

 

As for the virus/trojan alerts installing the TFD 1.03 they are false positives and can be safely ignored.

 

And remember to set compatibility mode to Windows 98/Me on RA95.exe and C&C95.exe.

 

 

Link to comment
Share on other sites

  • 0

Is your computer a brand computer? (Dell, Acer, HP etc.) If so try uninstalling all toolbars, docks etc that was preinstalled.

 

And you could try changing the resolution the games use.

Go to the games' folders and find ccsetup.exe (C&C1) and rasetup.exe (RA) in the C&C1 and RA1 directories and change the resolution.

Link to comment
Share on other sites

  • 0

I ran the DxDiag thing. Think it didn't find any problems I dunno...

 

And I never install any toolbar stuff into browsers, so i don't have any of those if thats what you mean...

I tried to set different resolutions in c&c's and ra's setup to no effect whatsoever I also tried other stuff in those and nothing. I tried to set screen resolution to 640xsomething in c&c's exe and 256 colors on but it only changed the colours/reduced the resolution for a moment before jumping back to desktop.....

 

And what do you mean by a dock?..

 

Opening the resolution change window through the desktop that pichorra was talking about for the duration of the game doesn't change a thing.

I tried ending the explorer process also, but i'm afraid I just killed something more than just the process.......... well i dunno if it helped because i cant get to my folder with c&c anymore :D

Hmm well... I guess I'll be back later with this problem when I have more time.. But thx for the help anyways. 0/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...