Jump to content

Dune II Unofficial Gravis Ultrasound Patch (for DOSBox)


MrFlibble
 Share

Recommended Posts

Not long ago I've configured DOSBox for Gravis Ultrasound emulation (which allows for high-quality synthesized music), and while browsing for possibly useful files, I found a very old unofficial patch that added GUS support to Dune II. Unfortunately, that patch does not work well with DOSBox, but the principle behind it allowed me to make a suitable replacement. The simple trick behind the patch is that the setup programme tells Dune II which drivers and sound files to use, so replacing certain drivers with GUS drivers does the job. For the patch, I replaced the Sound Blaster driver with the GUS digital driver, and the MT-32 driver with the GUS MIDI driver. That way, you can use the Sound Blaster Pro for SB emulation if you want to, and you can still select Sound Canvas (which replaces the Tandy 3 voice option) too, although it is recommended that you use the original Dune II setup and sound files if you want Sound Canvas-synthesized music.

 

Download Dune 2 Gravis Ultrasound Patch

(Download link courtesy of Nyerguds)

 

To install the patch, simply extract the following files into your Dune II directory, overwriting the old files when necessary (it is advised that you make a back-up copy of the old files first):

 

DUNE2G.BAT

DUNE.CFG

SETUP.EXE

SETUPENG.DIP

SOUND.PAK

 

The DUNE.CFG file is already configured to use Gravis Ultrasound for sound effects, speech and synthesized music, so if you do not want to change this, simply run DUNE2G.BAT to play Dune II with GUS music and sounds. For more information, refer to the patch readme file supplied in the package.

 

NOTE: It is assumed that you already have DOSBox installed and configured to emulate Gravis Ultrasound. If that is not the case, please refer to the information concerning Gravis Ultrasound emulation in DOSBox Wiki:

http://dosbox.com/wiki/Sound#Gravis_Ultrasound

 

For general information about DOSBox, visit their home page:

http://dosbox.com/

Link to comment
Share on other sites

Well, got ultrasound working (the guide op that thread does forget to mention you still have to do the basic enabling by setting "gus=true"), now on to Dune II :D

 

By the way, which game version is that patch for?

 

Another note... don't call readmes just "readme.txt", it tends to overwrite files.

 

Also, I don't know if you made that batch file, but...

  • "@echo on" is NEVER needed at the end of a batch file
  • you don't have to set the ultrasound folder in the path if you just run make it run "%ultradir%\ultramid" ;)

 

@echo off
if not "%ultrasnd%"=="" %ultradir%\ultramid -f -q
if not "%ultrasnd%"=="" %ultradir%\ultramid -16 -m115 -q
if errorlevel 1 goto done
dune2.exe
if not "%ultrasnd%"=="" %ultradir%\ultramid -f -q
:done

 

I uploaded it here, with the adapted batch file (and renamed readme). I also changed the volume line in the readme to match the edited batch file ;)

http://nyerguds.arsaneus-design.com/dune/dune2patch/d2_gus_patch.rar

Link to comment
Share on other sites

By the way, which game version is that patch for?

It should work with all versions (I tested it with v1.0 and HS v1.07), since SOUND.PAK is identical in all of them.

 

However, for some reason I haven't figured out yet, using GUS for both sound effects and speech in Super Dune II Classic tends to crash it. Using Ultramid with SB for speech and sfx works fine though. (I think that it might be because the game seems to load the entire ORDOS.VOC into memory on the House selection screen, since the Mercenaries use Ordos voices, but I'm not sure)

 

Another note... don't call readmes just "readme.txt", it tends to overwrite files.

I was being lazy :laugh:

 

Also, I don't know if you made that batch file, but...

  • "@echo on" is NEVER needed at the end of a batch file
  • you don't have to set the ultrasound folder in the path if you just run make it run "%ultradir%\ultramid" ;)

 

@echo off
if not "%ultrasnd%"=="" %ultradir%\ultramid -f -q
if not "%ultrasnd%"=="" %ultradir%\ultramid -16 -m115 -q
if errorlevel 1 goto done
dune2.exe
if not "%ultrasnd%"=="" %ultradir%\ultramid -f -q
:done

Actually I'm pretty inept at making batch files, and kind of didn't feel like looking for reference to make anything more decent. I copied the batch file from Blackthorne demo, and I added @echo on because upon exiting it would display this

Thank you for playing Dune II.C:\DUNE2\>

while with @echo on it gets

Thank you for playing Dune II.

C:\DUNE2\>

and besides, it seemed logical :D Maybe a simple empty line at the end would have done just as fine, but I didn't check that.

 

I've tried using %ultradir%\ultramid without having C:\ULTRASND included in the PATH variable, but for some reason it did not work at all for me, resulting in something like "illegal command %ultradir%\ultramid". Maybe I was doing something wrong...

 

I uploaded it here, with the adapted batch file (and renamed readme). I also changed the volume line in the readme to match the edited batch file ;)

http://nyerguds.arsaneus-design.com/dune/dune2patch/d2_gus_patch.rar

Once again, thanks! :D

Link to comment
Share on other sites

Actually I'm pretty inept at making batch files, and kind of didn't feel like looking for reference to make anything more decent. I copied the batch file from Blackthorne demo, and I added @echo on because upon exiting it would display this

Thank you for playing Dune II.C:\DUNE2\>

while with @echo on it gets

Thank you for playing Dune II.

C:\DUNE2\>

and besides, it seemed logical :D Maybe a simple empty line at the end would have done just as fine, but I didn't check that.

 

OK, some pointers then:

  • The @ is the same thing as the "echo off" effect. Instead of "echo off" at the start, you could technically make all lines start with @. Obviously, even when disabling echo with "echo off", that first command has to have the @ before it because the echoing isn't disabled there yet. Hence the "@echo off".
  • echo is used to print lines. An empty line can be produced with "echo." without a space between the command and the dot. Empty lines in a batch file are ignored.

 

I added that "echo." line in my script, too ;)

Link to comment
Share on other sites

Thanks for clarifying that :) My knowledge of DOS syntax isn't perfect, and I've hardly ever made any batch files myself.

 

As I mentioned elsewhere, your batch file works perfectly :D I must have been typing something wrong so %ultrasnd%\ultramid didn't work for me.

Link to comment
Share on other sites

Not surprising. It's not %ultrasnd%\, it's %ultradir%\ - it's a different variable :P

 

Usually, programs set a bunch of variables for the same thing... like my old computer Temp folder.

Set TEMP=C:\WINDOWS\TEMP

SET TMP=C:\WINDOWS\TEMP

SET TEMPDIR=C:\WINDOWS\TEMP

SET TMPDIR=C:\WINDOWS\TEMP

 

i'll not be surprise if there are 99999999 types of Ultrasond directory. :P

Link to comment
Share on other sites

Not surprising. It's not %ultrasnd%\, it's %ultradir%\ - it's a different variable :P

Ouch, I meant exactly that - %ultradir%. I just checked, when I type

C:\>%ultradir%\ultramid -16

it tells me that it's an illegal command. Or is this type of syntax only supposed to work in batch files (the batch file forks fine, as I said above)?

 

On the other hand, when I embedded DOS32A in some other games' executables, I followed the instructions and used the command

set dos32a=c:\dos32a

and then typing stuff like

C:\GAME\>dos32a\binw\sb /r game.exe

worked perfectly (although typing the full path to sb.exe would have worked just as fine). Why doesn't typing ultradir\ultramid (with or without %'s) work the same way, if it is also defined by the set command:

set ultradir=c:\ultrasnd
?
Link to comment
Share on other sites

Ouch, I meant exactly that - %ultradir%. I just checked, when I type

C:\>%ultradir%\ultramid -16

it tells me that it's an illegal command. Or is this type of syntax only supposed to work in batch files (the batch file forks fine, as I said above)?

Odd, especially since I tested this out without batch file before implementing it.

 

On the other hand, when I embedded DOS32A in some other games' executables, I followed the instructions and used the command

set dos32a=c:\dos32a

and then typing stuff like

C:\GAME\>dos32a\binw\sb /r game.exe

worked perfectly (although typing the full path to sb.exe would have worked just as fine). Why doesn't typing ultradir\ultramid (with or without %'s) work the same way, if it is also defined by the set command:

set ultradir=c:\ultrasnd
?

Are you sure you didn't just add a backslash before that entire command?

\dos32a\binw\sb /r game.exe

This will just execute it from the absolute path c:dos32a\binw\ as long as C is the drive you're on. An absolute path that's only drive-relative. It's completely unrelated to the environment variable you set.

Environment variables can only be called by surrounding them with % signs.

Link to comment
Share on other sites

\dos32a\binw\sb /r game.exe

This will just execute it from the absolute path c:dos32a\binw\ as long as C is the drive you're on. An absolute path that's only drive-relative. It's completely unrelated to the environment variable you set.

Environment variables can only be called by surrounding them with % signs.

Actually, the DOS32A instruction at DOSBox wiki says to use %dos32a%\binw\sb /r, but since this did not work for me, I omitted the %'s, and it worked (as it turns out, for a different reason). Maybe DOSBox 0.74 has some trouble with that?

Link to comment
Share on other sites

\dos32a\binw\sb /r game.exe

This will just execute it from the absolute path c:dos32a\binw\ as long as C is the drive you're on. An absolute path that's only drive-relative. It's completely unrelated to the environment variable you set.

Environment variables can only be called by surrounding them with % signs.

Weird enough, but trying to launch ultramid.exe using the absolute path method

C:\>ultrasnd\ultramd -16

didn't work either... Some oddity in DOSBox, I suppose.

Link to comment
Share on other sites

YOUR DosBox maybe... mine does it fine. I suggest updating -_-

AFAIK v0.74 is the latest one :) I'll test this enhanced SVN build, but I think that actually it's me having screwed up something unintentionally - because otherwise your BAT file wouldn't work for me (I suppose).

 

OR maybe it has something to do with my keyboard layout, or maybe some other regional settings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...