Jump to content

Do Base Nodes stop Action 125 Build Building at?


Recommended Posts

Hi, Ive just come up yet another action that should work, but now does not. I know it works on a YR Single Player Mission because Ive used it. However now it comes to repeating the action on a Red Alert 2 map.....it doesn't work.

The Action 125 Build Building at..... (Waypoint & Building type from dropdown list). Ive tried different Events, and re-written the Trigger under a couple of different conditions. Ive looked at the coding in word, and all appears as it should.

My only thought now is that the inclusion of Base Nodes on the map may have cancelled this action. Is this a known issue?

Here's the coding from the problem map. RA2


And here's the code from one that works, YR.


Aside from the building type nothing seems amiss Could this be an example of the Code requiring the Waypoint Number rather than the two Letter code? As the Waypoints are 43,44,45,46 and 47. And I don't see those but do see the number '10', repeated.

Link to comment
Share on other sites

ive used this trigger action a lot, and ive found that it wont fire properly if there is already a building there, or if the terrain dissalows it. when you use the action, the very top corner of the building will be at the waypoint, so keep that in mind. fa2 handles the action fine, though. ive used it in 400+ waypoint maps.

this might have been an action that they added just for yuris revenge. so it might not work in ra2

  • Like 1
Link to comment
Share on other sites

Your quite right, although the action is in the FA2 (original release) editor, it does nothing.

I've just been experimenting. Interestingly enough 01000022=1,125,10,20,0,0,0,0,I it gives a number to the building.  '20', --- but changing this to NALASR, made no difference. It fails to fire. So no having tried a number of permutations it looks like it doesn't work in the standard RA2 game. Base Nodes it is then......

Link to comment
Share on other sites

And still I didn't give up, I swapped the '10' for a '0', to see if that would make it work, I swapped the Building name for the number on the list along with it. So I think Ive now tried everything, and eliminated that Action for RA2.

Next one Ive found not working is an Event Spy Enter as infantry.

Just doing a little each day adding things , its slowly taking shape. Still got a load of others I need to upload.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...