Jump to content

C&C95: The instruction at 004386b1 referenced memory at ....


Recommended Posts

I've only had this error once and I'm providing the info just in case it's helpful in the future. I don't expect it too be fixed or anything, I'm just happy that C&C multiplayer is finally working reliably! Thank you all for your dedication!!


So here's the crash info:

Both computers crashed at the same time with the same message (except the memory location was different).


Computer 1 displayed the message in the screenshot. I also copied the windows problem thing:

Problem signature:

  Problem Event Name: APPCRASH

  Application Name: C&C95.exe

  Application Version:

  Application Timestamp: 32dd83d5

  Fault Module Name: C&C95.exe

  Fault Module Version:

  Fault Module Timestamp: 32dd83d5

  Exception Code: c0000005

  Exception Offset: 000386b1

  OS Version: 6.1.7601.

  Locale ID: 3081

  Additional Information 1: 0a9e

  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

  Additional Information 3: 0a9e

  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


Computer 2 had the same message as shown in the screenshot but instead said:

Application Error: C:\Westwood\C&C95\C&C95.exe

The instruction at 004386b1 referenced memory at 0483400a

The memory could not be read from

Click on OK to terminate the application


Both computers running Windows 7 Pro and fully updated. Game was running over the network; CnCNet was NOT in use(game was started using C&C95.exe, not cncnet.exe). Game had just started. Both computers were running the same version from the same source - v1.06c R3 (from Nyerguds site). Both computers had the default settings except: Computer 1 had window mode enabled and Computer 2 was running in full screen at a resolution of 800 x 600. Computer 1's humvee was about to pick up the crate shown on the map in the screenshot.


Hope this helps. Thanks again!


Link to comment
Share on other sites

Instruction address 004386b1; yeah, I know that one. It happens when a unit picks up a crate that explodes and makes the unit die with that explosion. The error itself is that it can't find the unit object to make it die. I have no idea what causes it, and it doesn't seem to happen when I test it in Skirmish mode.


Your screenshot is an interesting one though. It shows the unit is executing a chess-horse move (2 cells in one direction, one in the other; the game makes that move in a special way); otherwise it wouldn't be that far away from the crate at the moment it triggers it. That could be a clue...


There is a listing of all reported and fixed crashes here, in my crash research thread in the C&C95 v1.06 forum:


Link to comment
Share on other sites

  • 2 weeks later...

Agree with Nyerguds here.


Its interesting, because the unit has yet to pick up the crate (physically be in the place).


That means the pathfinding has created a path to the end and is checking to see if the cell is occupied before it moves to the next one in this picture and the crates are registered at that moment.


This gives more insight into the type of pathing used in C&C95 and it also points to the possibility of some issue with the cell pathing reading certain types of crates.


It could be that the crate doesnt exist anymore in the exe, instead of the unit in memory; otherwise it would break for other crate pickups (assuming same logic used). (Noted that other death crates work fine)





Link to comment
Share on other sites

Its interesting, because the unit has yet to pick up the crate (physically be in the place).

Actually, this kind of stuff also happens with crates that spawn units. The crate is picked up at the moment the unit that picks up makes the last maneuvre that would get it to the crate. Unlike celltriggers, crates are picked up when a unit touches it, rather than when they enter a cell.


An annoying mission side effect of this (especially for steel crate logics) is that infantry can pick up crates without triggering the celltrigger below it, if you move them back right after they only slightly touched the crate.


So... the crate mistery has been solved?


The time needed to reproduce it will be... long. :P

Wrong on both. Sandbox Skirmish mode, full game speed, on an exe rigged to always use the explosion crates. I've actually tried that before, without result. I have no idea if I tried the chess horse move though.


And even knowing what might cause it won't necessarily bring me closer to fixing it. I know nothing of C&C's path finding logics.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...