Jump to content
  • 0

Tiberian sun internal error with Campaign/Skirmish/Anything.





I got C&C Tiberian Sun + Firestorm, and in short, it doesn't work. The problem? It immediately crashes when attempting to launch any campaign mission or skirmish, with an error message saying "Tiberian Sun has encountered an internal error and cannot continue normaly." and says to visit westwood site for support.


Even more strange, when I open the skirmish window, there are NO SIDES TO CHOOSE FROM. No GDI, no NOD - just empty. WTF?


I've tried to download the game from multiple sources, including the official one, as well as the full installer version from this forum (Link). The issue remains, no matter which version I try, so it seems the problem is on my end. Weird, since I used to play vanilla Tiberian Sun without problems.


I have searched the web for a possible fix, but there is no sign of this issue, for some reason. When people talk about this error, it's usually about multiplayer, or random crashes mid-game, but I've never seen anybody talk about it crashing even before the actual mission is started. Why do I always have luck with obscure and rare errors like that?


Screens in attachments.



Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Incomplete instal is what came up to my mind too at first. But seriously... I've tried 5 different downloads, including the official one, and also including one that had numerous positive comments below it, saying it works.


Yes, of course I do have admin permissions. As for the antivirus, AVG is quite a paranoid and invasive antivirus I guess, but I had it turned off during the instalation, so I doubt that the problem lies here.


Thanks, I'll try your version. Probably won't help, but since I'm out of ideas at the moment, I'll check it out.

Link to comment
Share on other sites

  • 0

Have you tried running TS on Virtual Machine?

No. Why?



For shits n' giggles you could try this version I've been working on, on and off for a while: http://tore29.com/tsins/TSinstaller-beta7r4.exe

I just tried this version and still the same problem. Installed with antivirus and firewall turned off. At the first run there's an error "One or more DLL files were missing or damaged. Please reinstal.". At the second launch, the game starts up, but of course crashes with the error from OP when trying to start the campaign or skirmish.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...