Jump to content
  • 0

Tiberian Sun problems(Win 8, video mode error)


Tiberium
 Share

Question

I installed TS recently and when I first started the game up I noticed my cursor change and the screen freeze for a second followed by the error  "unable to set video mode" moments later. I looked into fixes on my own and got lost quick, I really have no idea how to fix this. I heard stuff like updating video card drivers( which where already updated for mine) and installing directx9 which I already had for older games on steam... I think.  to messing around with the "sun.ini" file (which does not seem to exist on the version of the game from this site) its under "SUN .configuration file" extension in the directory). Anyway after trying a quick fix from this site http://www.thegameengine.org/tiberian-sun/tiberian-sun-windows-8/ I gave up for a moment when i came across the video settings for the configuration file I just set it to 1920 width and 1080 height and launched the game again and it worked...kinda now the game looks zoomed out from the menu and I dont know how to fix it...

28ldg1g.png

 

So right now the only changes I made where adding

ddraw.dll

libwin.dll

wined3d.dll

 

extensions to the SUN directory and the 1080p upscaling in the configuration video options as well as enabling reduced color mode, 16-bit under the compatibilty tab. I'm just gonna leave settings as is until I find a real solution.

 

 

Also... when playing, the game lags a lot.

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

to messing around with the "sun.ini" file (which does not seem to exist on the version of the game from this site) its under "SUN .configuration file" extension in the directory).

Windows hides file extensions it knows (like that".ini") by default, and replaces them by a description like that "configuration file". As you just experienced, that seriously cripples your ability to make any sense of your own files.

 

Do a quick Google search for 'show extensions windows 8' and you should find out how to make them visible.

 

and it worked...kinda now the game looks zoomed out from the menu and I dont know how to fix it...

There is nothing to fix. The graphics are simply that size. Did you think changing the game's resolution would magically give the game higher resolution user interface? The videos can be stretched to fullscreen by the game engine, but the rest of the graphics can't.

Link to comment
Share on other sites

  • 0

"unable to set video mode" just means the chosen resolution is not supported, thats why it worked when you raised it :) you can try something lower like 800x600 1024x768 1280x720

 

I installed the files u sent and changed settings in configuration file and in game to 1280x720 and it helped got menu bigger it wasnt fullscreen, but it went fullscreen when I started playing which was what I wanted all along thanks for the tip :D. Just noticed one thing, forgot older C&C's like TS have u pan cursor to edge of screen to move camera was used to directional pad or wasd keys.  XD

 

The nostalgia though was worth it, still a great game, heck Cabal was worth it alone.

 

 

[Edit] PSA: Just so others know who may have same issue, I left the files from that site in my original post in plus the ones suggested, all in the directory and it worked for me. Just make sure under compatibility u enable reduced color mode 16-bit.

Link to comment
Share on other sites

  • 0

Windows hides file extensions it knows (like that".ini") by default, and replaces them by a description like that "configuration file". As you just experienced, that seriously cripples your ability to make any sense of your own files.

 

Do a quick Google search for 'show extensions windows 8' and you should find out how to make them visible.

 

There is nothing to fix. The graphics are simply that size. Did you think changing the game's resolution would magically give the game higher resolution user interface? The videos can be stretched to fullscreen by the game engine, but the rest of the graphics can't.

 

Done thanks for the tip, nope I just wanted a fullscreen view.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...