Jump to content

Tiberian Sun installs in Windows 10 but won't run


Recommended Posts

Got a new Windows 10 laptop, tried to play Tiberian Sun on it.


I had an error about comclt32.dll being old and, if I did not update it, to run vbrun60.exe from the Setup folder after the install, then reboot and run - which I did.


I cannot get it to run at all from the desktop (file Sun.exe). As admin, or in XP SP3 compat mode - nothing


Running autorun from the CD now gives an option to PLAY - but whether I run autorun as normal, as admin, or in compat mode at XP SP3, once I click PLAY the computer does nothing!


I don't want to play online, just the GDI/NOD missions (USB dongle internet, you see...)


Does anybody have any ideas? Thanks.

Link to comment
Share on other sites

Thanks. I guess I didn't quite understand the nature of this site, as I was running the original Tiberian Sun CD from 1999.


So far I've got "one or more dll files were missing or damaged. please reinstall.", then "unable to set video mode" when I run as administrator. I'll have a search on this forum and see if there's a solution.


Edit: To be more precise, I get the splash screen up,and when I select Single Player, the video mode error appears. I don't appear to be able to find anything for Tib Sun on Windows 10 on this site... does anybody have any ideas? Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...