Jump to content
  • 0

Mouse scroll to the side or bottom Red alert 1


Andrewshore
 Share

Question

I Patched my Game and Finally Got it starting now i need it to function with mouse either it bumps to the side or to the bottom any got a fix on this ???? Btw i am new to this kind of patching :)

A week of no replies  :puppydog: :puppydog: -_- I Finally got it started in windowed mode but the mouse keeps going either to the bottom of the screen or the side should i record a video for you of it

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I believe the answer to the C&C1 problem is actually in the video, at 5:31, in the FAQ of the RA installer... the "display scaling" thing. That, or the game executable is still set to "run in 640x480" compatibility mode, but that seems kind of odd since I'm fairly sure my patch disables all of those compatibility modes.

 

As for RA, you just ran it windowed; not sure what the problem is there. You can release your mouse from the window by pressing ctrl+tab if I remember correctly.

Link to comment
Share on other sites

  • 0

Seems like you have the DPI scaling problem when you run the game in fullscreen, maybe it is messing with the game in windowed mode as well.

 

Some of the screen is cut off when i am in game/i cannot see the side/bottom bars

 

Disable DPI scaling, set it back to the original 100% setting:

http://www.sevenforums.com/tutorials/443-dpi-display-size-settings-change.html

 

If you do not wish to disable DPI scaling globally you can do it for each individual game by following the instructions below:

 

Command & Conquer (Tiberian Dawn):

Right click on C&C95.exe (cnc95.exe for CnCNet), click on properties, go to compatibility and check "Disable display scaling on high DPI settings".

 

Red Alert:

Right click on RA95.exe (RA95-spawn.exe for CnCNet), click on properties, go to compatibility and check "Disable display scaling on high DPI settings".

 

Tiberian Sun:

Right click on game.exe (game-spawn.exe for CnCNet), click on properties, go to compatibility and check "Disable display scaling on high DPI settings".

 

Yuri's Revenge:

Right click on gamemd.exe (gamemd-spawn.exe for CnCNet), click on properties, go to compatibility and check "Disable display scaling on high DPI settings"

 

Otherwise the game might scale itself out of your monitor.

Link to comment
Share on other sites

  • 0

Hmm. Could you try could opening ddraw.ini and disabling the "mouse hack" option? Then try playing the game in fullscreen mode, and see if that fixed it.

 

(This will probably mess up the game if you try windowed mode, because the mouse hack is exactly to fix the relative offset of mouse position in windowed mode)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...