Jump to content
  • 0

C&C95 Crash issue.


Dybdal
 Share

Question

Hey all, hope im not intruding on your forum but this seemed to be the best place to get help with this issue i have.

 

Been playing Covert Ops lately with Nyerguds latest patch when i hit a rather annoying crashing issue thats very persistant. '

In the second GDI mission in the New Missions list (cant remember its name) i cannot scroll the screen to the very left edge without the game crashing to the desktop with this error code:

 

The instruction at 004b4002 referenced memory at 00000000

The memory could be read from

 

The bug happens in every mode, windowed, fullscreen, every resolution.. and it allways happens when i scroll the screen to the left side (it dosnt get to the edge, it will crash before it hits it) i can play the mission as long as i dont scroll the screen near the left edge but the kinda makes the map uncompletable.

 

help?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The game is crashing in the Radar code.

It's the mission where you start off with 2 Commando's you are refering to, correct?

Weird, don't get that issue in GDI Mission 2 Blackout.

 

Open conquer.ini and find [Options], try adding and toggling HardwareFills and VideoBackBuffer (they probably will be there already).

 

[Edit]

Seems Nyer has fixed this already http://forums.cncnz.com/topic/15009-crash-research/?p=190361 so that's weird.

Are you sure you are up to date to C&C95 v1.06c revision 3? Unless Nyer broke it again it doesn't make sense that this still happens.

 

Link to comment
Share on other sites

  • 0

The game is crashing in the Radar code.

It's the mission where you start off with 2 Commando's you are refering to, correct?

Weird, don't get that issue in GDI Mission 2 Blackout.

 

Open conquer.ini and find [Options], try adding and toggling HardwareFills and VideoBackBuffer (they probably will be there already).

 

[Edit]

Seems Nyer has fixed this already http://forums.cncnz.com/topic/15009-crash-research/?p=190361 so that's weird.

Are you sure you are up to date to C&C95 v1.06c revision 3? Unless Nyer broke it again it doesn't make sense that this still happens.

 

Thank you for the reply.

The 2nd mission in my "New Game" list isnt Blackout, its Hell's Fury

Yes im sure im running 1.06c Rev3 its installed ontop of the First Decade installation. (i've even tried re-installing the patch again, with the same results)

 

Tried HardwareFills and VideoBackBuffer 1 & 0 respectively with no success.

 

And i did some more testing and yes you are indeed right its linked with the Rader as selling the building fixes the issue and i cannot change the zoom level of the minimap without crashing with the same bug.

 

Any other ideas?

Link to comment
Share on other sites

  • 0

As far as I know, this error means there's an object on the map that doesn't have graphics in the terrain set you're using, and it crashes specifically in the code that tries to resize those nonexistent graphics for showing it on the minimap. Though why it would crash when you scroll I really don't get, unless you use the minimap in zoomed in state. Last time this happened (due to some code of me accidentally corrupting a terrain object's ID so it got saved wring in savegames) this crashed when the object was revealed by exploring the map; not by just scrolling.

 

Does this happen every time you try the mission, or is it one specific savegame?

Link to comment
Share on other sites

  • 0

I havnt tried it on multiple saves, allthough i do know that the minimap was indeed zoomed in as the save was done just as i built the radar.

 

Completed the mission by selling the Radar & Advanced Rader and going on without them.

 

When i get the chance to get some time to play again, i'll play the mission again to see if the bug persists.

Link to comment
Share on other sites

  • 0

100% sure that i had 1.06c on it, cc95v106c_r3_en.rtf was inside my installation folder before i reapplyed the patch from ModDB to make sure that wasnt what caused it but so was 1.06b so maybe something got messed up or something when i patched over 1.06b i dont know.. but i can say with confidence that my minimap allways starts out being zoomed in as was the case with the original DOS version.

 

Does that mean there is something wrong with my installation? or the way i applyed the patch?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...