Jump to content
  • 0

Cursor blinking, solution? RA2 YR


hippox89
 Share

Question

When I'm playing RA2 YR, and I'm moving the cursor to the sides or top/bottom to scroll then the cursor will blink in and out of existence. It's quite annoying. I've tried changing all of the settings available in CnCNet5, but it doesn't help. I have this issue on my PC with a Nvidia 630GT card, however, on my PC with an AMD HD 4980 the cursor is always solid/proper.

 

Is this a known issue?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Ahhhh, I found out that I also have this issue with Tiberian Sun. In TS the cursor will flicker constantly, and if I try to open the menu in-game then the game will seem to freeze, however, I can hear that the menu is actually open, but I'm stuck at the frozen screen of the game then I have to kill the process. This happens with two different PCs of mine, and both are using nvidia cards (630GT and 560TI). Again, my PC with an AMD card has no such issues at all. What do to, what to do.  :ranting:

Link to comment
Share on other sites

  • 0

Hi, Tore. Windows is 7 SP1 64-bit and fully updated. I downloaded TS from cncnet.org today.

 

Anyhow, I did some troubleshooting, and I found that the issue is related to 'no video memory' with Nvidia cards (at least my own cards/drivers)

 

Default render = mouse flicker, the menu doesn't work

TS-DDraw = issue is fixed, however, heavy input latency on mouse Edit: menus works but are very slow to respond!

IE-ddraw = mouse flicker, the menu doesn't work

ddwrapper (with no video memory set to 'on') = issue is fixed, however, heavy input latency on mouse and also very low game performance.

 

I would like to use 'TS-DDraw' expect for dealing with the input latency, but I noticed that there's no ddraw.ini in the TS folder. So how do I switch vsync off? Can you help with this? Thank you!

 

Edit: I thought TS was synced directly to the frame rate, but it seems not to. The point being, I can lower the input latency created by TS-DDraw by forcing the game to run at 58 frames instead of 60 (less CPU overhead) while still running the game at the same game speed. Hopefully this doesn't create sync issues between other PCs running at 60 frames, though. However, I still like to know how to turn vsync off with TS-DDraw. It's good to have options.

 

Edit2: So now it gets more messy, while TS-DDraw fixes the flickering mouse, it makes the menus very slow to respond. I just didn't notice this at first. Why can't the default render not just work properly.  :puppydog:

Link to comment
Share on other sites

  • 0

Just going to make a new post to make it less confusing.

 

So, I've found good solution now, it seems, at least.

 

The solution is to use TS-DDraw and force vsync off in the Nvidia control panel. This makes the game run at the original? 62 frames instead of 60 frames - and for whatever reason, this makes the in-game menu completely responsive again.

 

So, no input latency, no disappearing/laggy in-game menu, no flickering mouse cursor, good performance (though not extensively tested to be true).

Link to comment
Share on other sites

  • 0

Interesting. I have never tried using V-Sync on TS and as the game speed is tied to the frame rate problems could arise from that.

 

You could've attempted enabling the graphics patch as well.

 

One easy way to check if you performance is indeed good is to try and build something cheap.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...