Jump to content

Game slows drastically when scrolling.


Taramafor
 Share

Recommended Posts

I can only assume this was some attempt to slow down scroll speed (The normal freeware version scrolls like a cheetah on crack even on slowest speed setting).

 

When I scroll with this version of the game, which apparently is the freeware with "extras", the whole game is unplayable because scrolling itself makes the game slow to a crawl. What's more I noticed games in general were lagging afterwards so something was eating up my computer resources. A simple restart fixed that, but whatever those "extras" are shouldn't be affecting my comp outside of the game.

 

Meanwhile, is there any fix/workaround for either this or the standard EA freeware version? EA really should have let us play with ini files with this or something. I heard there was some config file for TD (Tiberiem Dawn, aka: the first C&C) involving reducing rendering or something but I'm not sure if that's possible here. Would using dosbox work? I can make do without online play since I'm playing more for the single player.

 

Oh, also the mouse cursor was flickering on and off in this version, which kind of makes the game unplayable as well because it's such a distraction and an eyesore.

Link to comment
Share on other sites

I assume you are using "TSinstaller3-beta11r6.exe" ? What windows do you have? You'll have to wait for tore, he should be able to tell us more about the settings he is using on your OS

 

You can also try to use the freeware version from EA, then apply TSpatch on top of it:

https://forums.cncnet.org/index.php?topic=3438.0

 

I am using the EA version. Patch did nothing to help with scrolling.

 

As for changing things in cncnet wouldn't that affect only online? It's a folder and not a file and has multiple other folders so I don't know which one to look into to change rendering when all I got is the name of the cncnet folder.

Link to comment
Share on other sites

I assume you are using "TSinstaller3-beta11r6.exe" ? What windows do you have? You'll have to wait for tore, he should be able to tell us more about the settings he is using on your OS

 

You can also try to use the freeware version from EA, then apply TSpatch on top of it:

https://forums.cncnet.org/index.php?topic=3438.0

 

I am using the EA version. Patch did nothing to help with scrolling.

 

As for changing things in cncnet wouldn't that affect only online? It's a folder and not a file and has multiple other folders so I don't know which one to look into to change rendering when all I got is the name of the cncnet folder.

 

What windows do you have? You can change the rendering via tsconfig.exe

 

By default the game doesn't work on windows 8/8.1/10, there are some workarounds that make the game playable but you end up with a slow scrolling bug. I guess you have windows 8/8.1/10 and added some workaround already?

 

The cursor flickering is also very typical for the windows 8/8.1/10 bug (the patch solves that)

Link to comment
Share on other sites

Oh, right. I'm on windows 10. And the patch was needed to even play the game due to the invisible in game menu bug, so I don't even know if there would have been any slow scrolling before the patch. TS_Ddraw gave me a desktop window in the middle and I had to force close it. The other settings just plain won't let me even start the game and says it's unable to set video mode.

 

Think using dosbox would work?

Link to comment
Share on other sites

Oh, right. I'm on windows 10. And the patch was needed to even play the game due to the invisible in game menu bug, so I don't even know if there would have been any slow scrolling before the patch. TS_Ddraw gave me a desktop window in the middle and I had to force close it. The other settings just plain won't let me even start the game and says it's unable to set video mode.

 

Think using dosbox would work?

 

Did you maybe move the game folder around to a different location? Make sure you use the TSlauncher to start the game, you will lose the registry keys that take care of problems like the "unable to set video mode" one.

 

Try to run TSlauncher as admin once, it could solve the problem. (Make sure you switch back to rendering=default first)

 

The game has no dos version, dosbox won't help you :P

Link to comment
Share on other sites

i'm on Lubuntu 16.04x64 and the game are slow too

acer travelMate 5720, With 2Gio Ram and SSD

but if i don't move the mouse, it's ok

 

Try ts-ddraw - In the game settings change the renderer to ts-ddraw, then in Winecfg set ddraw to native.

 

If ts-ddraw doesn't work for you then try default renderer ddraw(built-in) with Radeon fglrx binary driver,

 

Link to comment
Share on other sites

i'm on Lubuntu 16.04x64 and the game are slow too

acer travelMate 5720, With 2Gio Ram and SSD

but if i don't move the mouse, it's ok

 

Are you sure you used our download for ubuntu? (Debian package)

 

https://downloads.cncnet.org/tiberiansunonline_1.0_all.deb

 

I had the same problem when I just tried to run the windows installer without the needed dll overrides, the debian package should run without such problems

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...