Jump to content
  • 0

Command and Conquer Tiberian Sun Preformance Issue


MN_Chief
 Share

Question

I've noticed that EVERY time I build a structure (I use The First Decade of course and always have), the game would lagg intensely for about 2-3 seconds. This has been happened quite a lot sense the game released and I am wondering... is anyone else getting this? I have finally decided to talk about this sense Google wasn't a lot of help. I am not sure if it's because simply of the Operating System that I use (Windows 7) or it's just because the game is simply... old.

 

I have tried all sorts of compatibility modes but none of them work. I even tried to enable "Disable desktop composition" in the compatibility tab in the properties menus. And with my luck. It did not solve this at all.

 

The settings I use are at high details of course and the resolution is set at 1366x768 x 16.

 

Specifications

 

GPU: ATi Radeon HD3200 1GB

CPU: AMD Athlon TF-20 @ 1.6 GHz

Motherboard: No fuckin' clue

RAM: 3GB

HDD: 160GB

OS: Windows 7 Home Premium 64-bit

 

Thanks in advance,

-Gavin

 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

It the lag is more recognisable when building cheap things,

This is because of the gclock2.shp (Tibsun.mix\conquer.mix\gclock2.shp) which is the shadow which is shown over the top of the cameos when you build. There were afew posts on ppm and tibweb about it but i think the only solution was to shorten gcock2 by a few frames

Link to comment
Share on other sites

  • 0

Some graphics cards have insufficient Direct Draw compatibility and incorrectly handles some of the effects in Tiberian Sun, this causes the game to lag.

 

Some solution is to decrease Direct Draw acceleration in the dxdiag tool. Win + R and type in dxdiag. If you can't decrease acceleration then you are screwed.

 

You can try activating Direct Draw emulation with the Microsoft Application Compatibility Toolkit

 

There is a ddraw.dll lurking around that may fix your problem too-

Link to comment
Share on other sites

  • 0
It the lag is more recognisable when building cheap things,

This is because of the gclock2.shp (Tibsun.mix\conquer.mix\gclock2.shp) which is the shadow which is shown over the top of the cameos when you build. There were afew posts on ppm and tibweb about it but i think the only solution was to shorten gcock2 by a few frames

 

I don't get what you're trying to say. :/

 

Some solution is to decrease Direct Draw acceleration in the dxdiag tool. Win + R and type in dxdiag. If you can't decrease acceleration then you are screwed.

 

It wouldn't let me decrease the acceleration with the dxdiag tool. So I guess I am pretty screwed. Lol.

 

You can try activating Direct Draw emulation with the Microsoft Application Compatibility Toolkit

 

I had no idea what to do with it. :/

 

There is a ddraw.dll lurking around that may fix your problem too-

 

Well, I did find a ddraw.dll on the web just now but that causes an error when trying to launch Tiberian Sun that it will ask for KERNEL32.dll.

Link to comment
Share on other sites

  • 0

When you click on a structure in the sidebar, every other structure icon in the list will darken. This is because of a shp file in the mix that is laid on all the other icons, and causes the lag. I can't check the name of the file atm, because I have no XCC mixer installed here yet, but it wasn't gclock2 (that's used for the Firestorm IIRC). It was something like darken.shp.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...