Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Kaney

Windows 10 black screen

Recommended Posts

Hi, I've updated my laptop to Windows 10 and now when I start a game of ra2 or yr I get a black screen. Never had this issue on older versions of Windows. Any idea how to solve this?

Share this post


Link to post
Share on other sites

Try right-clicking on RA2/YR .exe files (or shortcuts), go to Properties, then the Compatibility tab. Check the Reduced colour mode option and set it to 16-bit (65536) colour.

Share this post


Link to post
Share on other sites

Try right-clicking on RA2/YR .exe files (or shortcuts), go to Properties, then the Compatibility tab. Check the Reduced colour mode option and set it to 16-bit (65536) colour.

 

I've tried that as well as the other compatibility options, it didn't fix it unfortunately. Any other suggestions?

Has anyone been able to run ra2/yr on win 10 without problems?

Share this post


Link to post
Share on other sites

What OS did you have before? Do you have an official/original installation of the game? Windows 10 is shipped with the needed settings for ra2 (same settings as for windows 8 ). But those only work on original installations

Share this post


Link to post
Share on other sites

Try playing using windowed mode. Also enable windows xp service pack 2 compatibility mode or windows nt or 95.

Share this post


Link to post
Share on other sites

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

  • Upvote 2

Share this post


Link to post
Share on other sites

You can just make sure it doesn't install in Program Files in the first place... the Origin install folder can be customized.

Share this post


Link to post
Share on other sites

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

 

 

These steps seem to have fixed it, thank you.

Thanks for your replies guys  :D

 

Share this post


Link to post
Share on other sites

Glad you've fixed it. Keep in mind that if you want to make any changes to aqrit.cfg file remember to use forcedirectdrawemulation = 1 and NoVideoMemory = 1. If you hav only one of tehm enable it will result in black screen and only sound.

 

Share this post


Link to post
Share on other sites

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

 

 

This seems to work for YR, but not RA2 for some reason - mine doesn't even want to run! I'm not sure if I had gamemdx64 installed before, which would enable the game to run...

Share this post


Link to post
Share on other sites

I decided to completely reinstall RA2 and YR as someone else on the TA forums did and fixed the game, but I've found another problem. I'm using the old game CDs and SETUP.exe refuses to run no matter what compatibility mode I choose, even with 16-bit colour mode. It, however, worked on Windows 7 64-bit somehow. I hope this doesn't mean I'll have to install it from my TFD disc and tell everyone who also has the 2000/2001 CDs to get TFD or TUC?

Share this post


Link to post
Share on other sites

I bought the c&c ultimate edition and first play was on windows 10, I had the same problem the thread relates to. I tried the fix and its the first luck I've had in days actually got a picture and started up a skirmish but the game froze and keeps freezing shortly into the game.

 

any ideas?

 

I did see something mentioned the other day about getting it to run using one core of the processor but cant seem to find it again and not sure if it would even work. I've got the later games but would just love to have a proper crack at the old fav again

Share this post


Link to post
Share on other sites

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

 

 

This seems to work for YR, but not RA2 for some reason - mine doesn't even want to run! I'm not sure if I had gamemdx64 installed before, which would enable the game to run...

 

Wat do you mean gamemdx64. YR is not a 32bit or 64bit. The file should be called gamemd.exe no x64 also please read carefuly the steps cuz for ra2 the file is called game.exe

Share this post


Link to post
Share on other sites

Wat do you mean gamemdx64. YR is not a 32bit or 64bit. The file should be called gamemd.exe no x64 also please read carefuly the steps cuz for ra2 the file is called game.exe

gamemdx64 is a special modification of the YR exe distributed with the TFD 1.03 patch: http://www.cncnz.com/hosted-projects/command-patch/the-first-decade-unofficial-patch/

 

And yes, kid, I do know RA2's .exe is called game.exe, perhaps I'd have known that after 14 years of playing RA2 and answering a bajillon support threads in the C&C community... -.-"

Share this post


Link to post
Share on other sites

Wat do you mean gamemdx64. YR is not a 32bit or 64bit. The file should be called gamemd.exe no x64 also please read carefuly the steps cuz for ra2 the file is called game.exe

gamemdx64 is a special modification of the YR exe distributed with the TFD 1.03 patch: http://www.cncnz.com/hosted-projects/command-patch/the-first-decade-unofficial-patch/

 

And yes, kid, I do know RA2's .exe is called game.exe, perhaps I'd have known that after 14 years of playing RA2 and answering a bajillon support threads in the C&C community... -.-"

 

1.Try adding this to ra2.ini file above everything:

[Video]

AllowHiResModes=yes

AllowVRAMSidebar=yes

 

2.make game.exe, ra2.exe and mph.exe windows xp sp3 compatibility and tick run as admin button too then try starting the game.Also make sure that you tried the first method with your monitor:

https://www.youtube.com/watch?v=2M9xOXxwK1g

 

3.If its still not wokring try again the method above but this time duplicate your monitor.

4.If stilll not working try changing your windows to 16bit mode and add " -win" witouth quotes to ra2 shortcut

 

And sorry for telling you about that file but i tend to explain in very detail for most of people.

 

Share this post


Link to post
Share on other sites

Wat do you mean gamemdx64. YR is not a 32bit or 64bit. The file should be called gamemd.exe no x64 also please read carefuly the steps cuz for ra2 the file is called game.exe

gamemdx64 is a special modification of the YR exe distributed with the TFD 1.03 patch: http://www.cncnz.com/hosted-projects/command-patch/the-first-decade-unofficial-patch/

 

And yes, kid, I do know RA2's .exe is called game.exe, perhaps I'd have known that after 14 years of playing RA2 and answering a bajillon support threads in the C&C community... -.-"

 

1.Try adding this to ra2.ini file above everything:

[Video]

AllowHiResModes=yes

AllowVRAMSidebar=yes

 

2.make game.exe, ra2.exe and mph.exe windows xp sp3 compatibility and tick run as admin button too then try starting the game.Also make sure that you tried the first method with your monitor:

https://www.youtube.com/watch?v=2M9xOXxwK1g

 

3.If its still not wokring try again the method above but this time duplicate your monitor.

4.If stilll not working try changing your windows to 16bit mode and add " -win" witouth quotes to ra2 shortcut

 

And sorry for telling you about that file but i tend to explain in very detail for most of people.

Note if its Yuri, its ra2md.ini which the client handles for you anyway.

Share this post


Link to post
Share on other sites

So I updated Nvidia GeForce drivers to 358.50 the other day and it totally fixed the black screen issues on Windows 10 for me. (Where everything else was failing to fix it)

Drivers released on: 10/07/2015

 

I hope this helps everyone else!

Share this post


Link to post
Share on other sites

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

 

 

i followed this step by step (but i confused on other things .. there were already an apps named "gamemd" and "game" so i renamed the main exe into gamemd(2) and game(2) . i tried instruction number 8 (but windows pack 3(compatibility issue)) and when i tried to play the game it states that "launcher config file is missng .. you must need to run on its install directory" ..

 

please help me .. i spent few hours for your insructions .. thanks btw

Share this post


Link to post
Share on other sites
On 8/3/2015 at 7:04 AM, RedSigma said:

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

I'm not sure if I'm necroing. But, I just want you to know that I registered just to say thanks to this.

Share this post


Link to post
Share on other sites
On ‎8‎/‎3‎/‎2015 at 3:04 PM, RedSigma said:

I found that this bug happen on windows 7 64bit and windows 8/8.1 too. Try unsing this method from the video. Maybe is somthing went wrong with your monitor settings and now you hav a duplicate monitor. Follow all the video steps and it should fix it.

 

https://www.youtube.com/watch?v=aFO1fEhoPDY

 

If this doesn't work follow use this method instead:

 

1. Copy the directory Red Alert 2 (Typically found in C:\Program Files (x86)) to somewhere outside of Program Files

2. Download the graphics patch from http://www.stuffhost.de/files/cnc/ and extract it into the directory that you just moved

3. Rename Yuri's Revenge to gamemd.exe, then run the patch to patch the game (for ra2, rename to game.exe)

4. Download http://bitpatch.com/ddwrapper.html zip file and extract the files to the directory that you've patched the game in

5. Edit aqrit.cfg in notepad and change these two settings to 1 as in below:

NoVideoMemory = 1

forcedirectdrawemulation = 1

6. Create a shortcut to the game and move it to your desktop

7. Go to properties and in 'Target' add at the end after " add -win

example Target: "C:\Users\Roberto\Desktop\Red Alert 2\gamemd.exe" -win

note the space between gamemd.exe" and -win

8. In the same Properties Tab:

Compatibility : Win Xp Service pack 2 (Seems to be most stable)

Reduced colour mode : 16bit

Run as Administrator

9. (Optional) Edit .ini file to change the resolution

10. Play the game

I just registered to say Thank you ! Red alert 2 is still crashing but yuri's revenge is working just awesome after doing this. Again thanks man 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...