Jump to content

I need help, please.


Recommended Posts

Ok, so I've been working on a new single-player campaign, and things were going well. But recently the editor has become really unstable. For the first few maps I made over the last couple of weeks things were fine, I got them all working, fairly well-balanced etc. but now when I try to make any new maps it just won't have it. I'll make a new map, save my progress and come back to it later and I get errors up the wazoo when I try to load it, other bugs and sometimes the editor won't even recognize my map files, or they won't appear when I try to load them back up. And yet the first 3 maps I made still load up fine. I understand the game is like 20 years old or something, but how can the editor go from working without a hitch a few days ago, to simply refusing to work? I'm just about to toss in the towel, but I figured I've put a lot of work in so I'd see if anyone can advise me on how to salvage it.


For example, my latest map I got to building earlier today. I've done nothing different than on my other maps but when I try to reload this new one now I get the error: 'Access violation at address 004069C6. Read of address 00000000.' Whatever that means. All the map is so far is a basic, campaign-style map with an enemy base and a few tanks and infantry around, I've not even got onto the triggers and 'worky bitz' yet.

And another issue I have is with my multiplayer maps. I made some quickly to test out some ideas, tried them out in-game, and when I went back to the editor to make adjustments the editor didn't recognize them, and they don't show up when I try to load them. Its like the files just don't exist, even though they are still in the right directory. They even still work in-game. The updated default editor that came with the game seems to work fine, too, but I much prefer using the new windowed scenario editor, but its a buggy mess atm. Is it just one of those things I have to work around or am I making some mistake, or will it ever get a fix? I don't know what to do, this is a cry for help, lol.


I know this got a bit ranty, it wasn't intentional but I wanted to make sure I'd said everything I needed to. Does anyone else have these problems and can anyone please help me? Cheers, guys.

Link to comment
Share on other sites

The crash is known, it happens when you try to load a map that doesn't have a name I think.


The editor got a bug where it sometimes doesn't save the map, so it's the best you check the file after saving to make sure it actually really saved it. If the file size is 0 byte then click the T icon in the top right and copy all text from there and save it to a file manually with notepad.


The best thing you can do is using the other editor for the terrain and only use the scenario editor for units/buildings/events


Note: the other editor can run in a window too, you can enable window mode in the config




Make sure your filenames are short and check all the map files in your folder with notepad to ensure all of them have a name

Link to comment
Share on other sites

Thanks for the reply. Its weird, after several name-changes the single player mission seems to work again (for now), but the multiplayer maps are still an issue. They have a correct filesize and everything, I tried copying them to a different txt file but that didn't work either. Everything else seems to be in order, so I don't have a clue why the base editor works but the scenario editor doesn't read them. The maps work in game, so I don't think it was a saving issue. I'll probably do as you suggested and swap to the old school editor for the terrain and multiplayer maps. Thanks.


Also to the Mod, it was about RA1 and apologies about the wrong forum.


Cheers, guys :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...