Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
netflixYR

error unable to set video mode

Question

i got windows 10 64 bit and yuri+RA2 give me  that "Error-unable to set video mode "

i download it from origin also tried pirated version and with pirated version RA2 works fine but yuri still gives the same error

Radeon Software Version - 16.5
Radeon Software Edition - Crimson
Windows Version - Windows 10 (64 bit)
System Memory - 6 GB
CPU Type - Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
 

Screenshot (16).png

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Hello,

Please try one of the following solutions:

  • Set your game resolution to the same resolution as your desktop. Navigate to Client Options > Display, and select the resolution and save.
  • Ensure your video drivers are up to date.
  • Remove RA2MD.ini

Share this post


Link to post
Share on other sites
  • 0

Yuri's Revenge is fixed at 800x600 at start up (game menu). My GUESS is that's what's causing the problem, and that you haven't installed CnCNet's Yuri's Revenge launcher (which shouldn't be necessary, but usually helps and also makes the game so much better).

Try the following (one at a time)...

  1. Change your desktop resolution to 800x600.
  2. Change the game's resolution in ra2md.ini (located in your game's installation folder).
  3. Download and install the previously mentioned CnCNet YR Launcher (the good old download-the-launcher solution!).
  4. Run the game in windowed mode.

Share this post


Link to post
Share on other sites
  • 0

Hello,

Please try one of the following solutions:

  • Go into your Red Alert 2 folder, in there you will find "game.exe", "gamemd.exe" "ra2.exe", "gamemd-spawn.exe" and "ra2md.exe", right click -> properties -> compatibility, Enable "Reduced Color Mode: 16bit"
  • Enable the "Disable Display Scaling on High DPI Settings" compatibility mode for all executables (see above)
  • Set your game resolution to the same resolution as your desktop. Navigate to Client Options -> Display, and select the resolution and save.

Share this post


Link to post
Share on other sites
  • 0

my lowest desktop resolution is 1024x768

 i have CnCNet YR Launcher

 i also try changing resolution under video in ra2md.ini file 

and also tried that windowed mode

 

nopes that didnt work tooo @FunkyFr3sh

 

Share this post


Link to post
Share on other sites
  • 0

Are you playing through the CnCNet YR Client or are you trying to start the original game?

If playing through the CnCNet Client, open the client Options, set Renderer to TS-DDRAW and Save.

Share this post


Link to post
Share on other sites
  • 0

actually i tried both cncnet and original game both give same error

and renderer is already on TS-DDRAW

 

Share this post


Link to post
Share on other sites
  • 0
On Monday, April 17, 2017 at 4:19 AM, netflixYR said:

my lowest desktop resolution is 1024x768

 

 

I think this is your problem right here: 'LOWEST'. The game is trying to set itself to 800x600 which is below the limits of your monitor. Try another monitor, even your tv for now just to see if it works.

Share this post


Link to post
Share on other sites
  • 0

but i think yuri and ra2 is also playable at 1024*768

that laptop got FHD display so that means yuri isnt playable on this?

Share this post


Link to post
Share on other sites
  • 0

No matter which resolution you pick, Yuri's Revenge sets the resolution to 800x600 for the loading screen, then uses the actual selected resolution only when the game has actually started. So your monitor needs to support 800x600 for the game to work.

RA2 supports higher resolutions in the loading screen already, which is why RA2 works but YR doesn't.

Edited by Rampastring

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, netflixYR said:

but i think yuri and ra2 is also playable at 1024*768

that laptop got FHD display so that means yuri isnt playable on this?

YR is indeed playable at that resolution, and much higher too, but only while actually in-game (with all the tanks, planes and so on), but not at the MENU. RA2 has no problems, which is why you've been able to play it. I've been able to play them at 2560x1440, but not any higher for some reason (I've been trying to play at 4K resolution, but both games keep crashing when I try to go higher than 1440p :( ), but that's another story.

The problem isn't that RA2/YR can't be played on a full HD monitor at higher screen resolutions, the problem is the MENU for YR, which is unfortunately FIXED at 800 x 600 resolution. Take a look at my display settings:

screen%20range%20full_zpsfcelp3zt.jpg

This is the entire range of my tv screen's capability. It is currently set to 1080p (or Full HD). I can set it from a low resolution, all the way up to 4k (4096 x 2160), and everything in between, mostly. Notice how even though my screen can go up to a high 4k, it can also go all the way down to a low 800 x 600, which is what is required for the YR menu. If you check your display settings, yours will more than likely only have 1024 x 768 at the bottom, which is the LOWEST it is capable of, but not low enough to play YR.

Keep in mind that these games are very old and were developed at a time when full HD monitors weren't around. To my knowledge, it is unfortunate that up to now nobody has been able to resize the YR menu :D

Share this post


Link to post
Share on other sites
  • 0

Sorry buddy, either constantly bug Rampastring^ everyday to modify the YR menu, or use another monitor/screen that is capable of the 800 x 600 screen resolution.

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, netflixYR said:

you know how to create a custom resolution?

width,height and refresh rate for 800x600?

I do but I've never had to, and frankly I'm afraid to try it :D

On my Radeon (Crimson) settings, which is the same as yours, or similar: Preferences -> Radeon Additional Settings -> My Digital Flat Panels -> Custom Resolutions.

Try it at your own risk, then let us know if it worked! :P

6 minutes ago, netflixYR said:

ohh i just create a resolution of 800*600 and it worked

What about the game itself (YR)?

Share this post


Link to post
Share on other sites
  • 0

i built that on Intel and that works 

and most of all i dont have to set it for my desktop 

well thanks to all who try to help ;)

 

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, netflixYR said:

i built that on Intel and that works 

and most of all i dont have to set it for my desktop 

well thanks to all who try to help ;)

 

So... does YR actually work now?

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, netflixYR said:

yea  it worked fine.... :)

Very nice! Another solution to add to my library :) . Well, I'd like to think we all contributed to lead to that solution :P But regardless... ENJOY!! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...