Jump to content
  • 0

Spawn Locations not showing properly


Kizake
 Share

Question

22 answers to this question

Recommended Posts

  • 0

Does anyone else have this problem?

Hello

 

What O/S are you running?

 

Have you just installed CnCNet? If so the rendering of maps takes a few minutes

This problem was present on the older version of cncnet. Normally is happening if the map is not loaded completely or is a bug with the "do not show spawn previews button" (wich is not working if you enable it).I also hav windows 7 but i think this is only a tunnel lag or something like this because it happened randomly for me.

 

Do you encounter this problem everytime you go on a server?

Link to comment
Share on other sites

  • 0
This problem was present on the older version of cncnet. Normally is happening if the map is not loaded completely or is a bug with the "do not show spawn previews button" (wich is not working if you enable it).I also hav windows 7 but i think this is only a tunnel lag or something like this because it happened randomly for me.

Sorry, but you have no idea what you're talking about.

 

Grant is correct, rendering the maps takes a while. If you still don't see high-res map previews after a few dozen minutes, make sure that you have .NET Framework 4 installed.

Link to comment
Share on other sites

  • 0

I am also having the same problem and its extemely annoying. Is this something specifically isolated to a few users. Seems like as many games that are going on daily there should be more discussion on this subject.

 

My friend and I have been just playing team alliance against multiple hard ai's with multiple teams but it sometimes takes up 5-6 tries to assign correct starting locations due to the maps not being rendered and spawn map locations are not showing up. This is happening on his machine too, both client versions of 1.62, both running win7, 100mbit+ internet connections, both with intel i7s with 12gb+ ram, updated nvidia/radeon video cards with newest drivers (displaying ra2 in 1080p res) and plenty of terabytes of available disk space for png renderings.

 

I've attached parts my log file as well as an ss of my screen.... hope this gets fixed (seems like it wasn't a bug until this version). I just got cncnet for ra2 about two weeks ago after hearing about the big update on sept 20th. Read that the preloaded png files were a 120mb file and the idea was scrapped due to it being too large? Doesn't seem too large to today's standards considering most games are 40gb+ these days.  Is there still a download file I can download and manually install them?

 

I've also read through all threads on this forum and read that the client renders it in the background lobby of cncnet yr, and that there should be .png files showing up in the Maps/Yuri's Revenge folder. No PNG files for me after letting the client sit idle overnight and all day at work 12+ hours total. Check my administrator permissions (including write-protection) and all seems in order.

 

Is there anything else I can do to help fix this problem?

 

 

 

9. 10. 16:45:37.248    Loading map Maps\Yuri's Revenge\MojoSprt

9. 10. 16:45:37.250    Loading map Maps\Yuri's Revenge\MonsterM

9. 10. 16:45:37.252    Loading map Maps\Yuri's Revenge\MoonPatr

9. 10. 16:45:37.254    Loading map Maps\Yuri's Revenge\RiverRam

9. 10. 16:45:37.256    Loading map Maps\Yuri's Revenge\SinkSwim

9. 10. 16:45:37.258    Loading map Maps\Yuri's Revenge\Transylv

9. 10. 16:45:37.260    Loading map Maps\Yuri's Revenge\Unrepent

9. 10. 16:45:37.264    Finished initializing maps.

9. 10. 16:45:37.351    Initializing DTA CnCNet client.

9. 10. 16:45:37.352    Attempting to resolve IP address for eu.irc.cncnet.org

9. 10. 16:45:37.423    Attempting to connect to the specified server 185.53.128.156:6667

9. 10. 16:45:37.533    Connection established succesfully.

9. 10. 16:45:37.538    Starting thread to handle commands.

9. 10. 16:45:37.634    WARNING: CnCMaps Renderer files not found.

 

<rest of the log file is just irc users ips/whois/join/quit etc>

 

 

 

Capturebug.JPG.57192e943ec38b997ee80e9388393ff0.JPG

Link to comment
Share on other sites

  • 0

Why not save the map images in JPG format? It'll be much smaller and faster to process. The quality should be the same because RA2/YR's graphics are very pixelated for today's standards, and even if the quality isn't as good, it's only for preview maps anyway.

Link to comment
Share on other sites

  • 0

Last time I checked, JPGs saved with the map renderer have a horrible amount of compression. It could be visible in the previews with a maximized window on high-resolution monitors.

 

I doubt JPGs are significantly faster to render.

 

As for disk space, surely 100 MB of map previews is no issue when you can buy 1 TB drives for ~60€.

Link to comment
Share on other sites

  • 0

Last time I checked, JPGs saved with the map renderer have a horrible amount of compression. It could be visible in the previews with a maximized window on high-resolution monitors.

 

I doubt JPGs are significantly faster to render.

 

As for disk space, surely 100 MB of map previews is no issue when you can buy 1 TB drives for ~60€.

Yeah you're right, less compression is definitely quicker. Not sure what i was thinking  :S

Link to comment
Share on other sites

  • 0

Hi again, after the update the file "Map Renderer" now exists

and i looked into the log and i found this entrys

 

12. 10. 22:45:58.060    Loading preview from Maps\Yuri's Revenge\XMP14T2.png

12. 10. 22:45:58.060    Preview file Maps\Yuri's Revenge\XMP14T2.png doesn't exist!

12. 10. 22:45:58.060    Attempting to extract map preview from the map file.

12. 10. 22:45:58.434    Unable to parse ForcedOptions from forced game options ini.

12. 10. 22:45:58.434    Unable to parse ForcedOptions from forced game options ini.

 

Is this good? or bad? :roll:

Link to comment
Share on other sites

  • 0

I was having this exact issue and I was able to fix it by copying the CNCMaps.Shared.dll from an old (8-12-2015) install into my new install.

 

I have windows 10, which includes .net 4, so I don't think .net is the problem.

 

I think it's missing that file which is the problem.

 

Now my maps are all rendering! It's taking a few minutes, but hey - I can see them and see the start spots.

 

 

Also, when rendering the maps, if you click on the map that's currently rendering, it crashes the game. Best to wait 10-15 minutes for them all to render.

Link to comment
Share on other sites

  • 0

Why not save the map images in JPG format? It'll be much smaller and faster to process. The quality should be the same because RA2/YR's graphics are very pixelated for today's standards, and even if the quality isn't as good, it's only for preview maps anyway.

jpeg is blurry, horribly smudges red colours, destroys all the kind of detail you'd want to see on a minimap preview, and unless you up the compression to make it even more blurry, there's not really a guarantee it will be smaller than png.

 

Simply put, it is a file format of the past. The only good use for it today is for raw photos.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...