Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
N3cro_Manc3r

Cannot run Tiberian Sun on windows 10

Question

Hello,

First of all you guys do a great job with keeping these strategy games alive! I always wanted to play Tiberian Sun; when it came out the game was too difficult for me. I bought The First Decade when it came out but here Tiberian Sun was unplayable due to a high number of defects. I thought I give a change again using your website, but as the title implies I cannot get Tiberian Sun to run on Windows 10. I have installed all of your patches, updated my Nvidea 970 Card drivers. The Skirmish mode works. But when I want to start with the campaign it get stuck on the loading screen, saying:

''creating theories on likely enemy plan''

I hope you have some suggestions on how to fix this problem.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

This has been posted here a few times already, I never managed to reproduce it and no one knows why it happens for some people.

But the fact that skirmish works is interesting, don't think anyone said something about that yet. With skirmish you mean playing via the CnCNet lobby, right?

 

If skirmish works via the CnCNet lobby, try the following:

Go to your game folder and make a copy of "game.exe" and name it "game-123.exe", now try to start the game via "game-123.exe" and see if that works. I know microsoft automatically detects old games by filename and some other conditions, maybe this problem is related to some compatibility modes that were applied by windows.

Share this post


Link to post
Share on other sites
  • 0

Yes skirmish works via the CnC lobby. Ingame it has the same problem as with the campaign. Creating a exe copy does not work unfortunately.

Share this post


Link to post
Share on other sites
  • 0

Oh I see.

Well, I remember I looked through the code longer time ago but couldn't guess what the problem could be. If I could reproduce it then I'd probably be able to fix it...

 

If you're tech-savvy you might be able to help out, there is a tool from microsoft named "Process Monitor", you could use it to create some logs and we might be able to tell where the game gets stuck.

 

If you want to try it, start "Process Monitor" and add a "Process Name" filter for "game.exe". Then start the game (preferable in windowed mode), start a mission and once it's freezing you'll have to check the output of process monitor, the last lines in the log could, maybe, tell us what happened in that moment.

Share this post


Link to post
Share on other sites
  • 0

Ok done, I think. I have attached the logfile.

/edit the logfile is from starting the game, to starting a skirmish ingame, to crash.

Logfile.rar

Edited by N3cro_Manc3r

Share this post


Link to post
Share on other sites
  • 0

That's nice! It looks like you exit the game before saving the log, is that correct?

I assume the last thing that happened was this:

00:14:09,4021551    game.exe    14640    50492    C:\Westwood\SUN\Civ03a.MMT    CreateFile    NAME NOT FOUND....

 

Could you maybe do it again (just to be 100% sure..)? Save the log before the game is being closed by you (run in window!).

 

 

It's searching for a lot of files, I assume if you do it again you might end up having a slightly different ending in the log. Maybe searching for the files is what makes it so slow... If you keep the game open for a minute or two then the log could be larger (Eventually the game will even start if you wait long enough).

Edit:

Wow, it took 6 seconds to search for these files! That's a long time... I guess we might have found the problem (kinda!).

 

I just did a comparision, for me it took only 100ms to search for the files... somehow you got extremely slow disk access... Your game actually doesn't freeze, it's just loading for ages (If you don't click, windows should not say that it froze).

What anti-virus you have? Something is slowing your PC down a lot...

Share this post


Link to post
Share on other sites
  • 0

Hello,

Yes I exited the game before saving the log. I started the log before i started the game, and it is constantly searching for game.exe when the log is on. So 6 seconds is from the moment that the game starts as a whole to breakdown. How do I start TiSun in windowed mode? My anti virus is AVG free. I have no other problems with my pc being slow, the game is even installed on a SSD disk.

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, N3cro_Manc3r said:

Hello,

Yes I exited the game before saving the log. I started the log before i started the game, and it is constantly searching for game.exe when the log is on. So 6 seconds is from the moment that the game starts as a whole to breakdown. How do I start TiSun in windowed mode? My anti virus is AVG free. I have no other problems with my pc being slow, the game is even installed on a SSD disk.

 

Oh I guess we don't actually need another log, when I compared mine with yours it was pretty clear that your game actually works fine, it just needs very long time searching for all the files. I don't think there is anything we can do with the game itself to improve it, it's something external like an anti-virus or bug that slows down the CreateFile winapi call.

 

One thing that *could* be done is patching the game so it doesn't actually search for loose files in the folder since all its files are located in .mix file containers, but this would be a bad idea since it would break all kinds of mods that people created where certain files were placed directly into the game folder rather than the .mix containers. It's better if you could find out what is causing this issue. I assume it happens with other applications too, but it may not be as noticeable as with tiberian sun since it searches for a lot of files (Your log only contained a few of them, if you keep the game running for a longer time it would grow a lot bigger)

Share this post


Link to post
Share on other sites
  • 0

Ok thank you for your help. I actually got the game running yesterday. Just as you said it needed a long time to load and I cannot interrupt it by clicking somewhere for instance. Other missions loaded quicker but every few minutes the screen freezes but the game keeps running. It can solve it by returning to desktop and then opening the game again but it is not ideal. I also tried shutting down al background software that I have but it did not seem to matter. When I have a final solution I will you know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By JaegerCrux
      I just performed a clean install of TS directly from CnCNet. The game starts up, the movies play flawlessly, the menus are totally functional. But upon starting a game, it crashes to the desktop at the load screen before any of the loading texts appear in the "screen." I get the dreaded "TS has encountered an internal error and cannot continue normally" error box, and that's it. I've attached the exception file. I'm running Win10 x64, I installed to the default directory, and my drivers should be up to date. I tried running it at 800x600, 1024x768, and native 1920x1080 resolutions. The TS Patch is installed; the error happened before and after it was installed, no change whatsoever.
      Thanks for the help. It's been years and I'd like to play what I haven't been able to play in a long time.
      except.txt
    • By Holland
      https://youtu.be/X6PPIJNVyt0
       
      Tutorial on ppmforums: https://ppmforums.com/viewtopic.php?t=44324
      Tunnel Drawer: https://ppmforums.com/viewtopic.php?t=37881
       
      Join us on the Final Sun discord server:  https://discord.gg/KbzvmG6
       
    • By kane105
      I installed the full download of Tiberian Sun and it works perfectly until the end of the second mission of the Nod campaign. After that the screen goes back and it gives the "Tiberian Sun Executable error" message and crashes. I've tried it a couple of times all with the same result. Is there any fix or anything I could try?
    • By AndrewFord
      on the CncNet5 (RA, TS, TD version) there is usually a flashing green button that says "streaming" whenever someone is live on twitch but it doesn't show anymore. When shall this be fixed.
    • By Nah
      Hi,
       
      I have some questions regarding Final Sun.

      Why does every time when I'm reloading my map in the editor the shape of all the Ice Ramps randomly get changed?

      Am I missing an option to disable  this behavior (slope correction is disabled) regarding the slope logic and the Terrain Ground 0009 feature?
      I'm using Final Sun that comes with the installer from https://cnc-comm.com/tiberian-sun/downloads/the-game/installer.
       
      Before

      and after reloading:

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...