Jump to content
  • 0

Tiberian Sun - Firestorm help request


T800
 Share

Question

Hello,

I need help in regards of slow savegame loading and lately some random crashes. I searched alot the internet for a solution, but couldn't find one. I emphasize, that it effects only Firestorm, at least i didn't faced with the followings, while playing through TS. The game version, what i play, is downloaded from CNCNet, but the current game directory containes the file, which i listed in the attached txt file.

Actually, even FS was working fine, until i reached the 7. GDI mission (The Cyborgs Are Coming). I used to save my game periodically and after some time, when saved and then attempted to reload the state, it took extremely long, which means about 1,5 hours! Once i was able to continue playing, after another bit of time spent, the reloading would took God knows how long, since after 3,5 hours i killed the Game.exe process. It looks like the game freezes, but in fact it doesn't, if one is patient enough, it'll be loaded sometime...

In addition, until now only in this mission, i encountered with crashes unexpectedly twice, when a popup appeared and informed me, that the game cannot continue properly this way, etc., stc.. I also attached the crashlog. Even though, until this point, i played the game on a Virtualbox XP Pro SP3 machine - with 1,25 GB of RAM and the maximal 128 MB VRAM - and after several trials, tested the game on a Windows 7 Ultimate 32bit VM too (with 1,25 GB RAM and 256 MB VRAM). At last, now i'm running it on an old physical machine (CPU: P4 3.4 GHZ, 3 GB RAM, Geforce  7950 GT VGA) and after hours, i'm still waiting for the game to be loaded. I already tried every imaginable variations of config values (in sun.ini, ddraw.ini, aqrit.cfg), then even updated ddraw to the latest version (1.1.4.15). It's also pretty weird, that even on the real PC, ddraw wouldn't use openGL rendering, only GDI, even though, the configuration is auto (attached a screenshot). One more thing worth to note, game starts to lag and slow down a bit sometimes, while i'm about after 65% of this mission. I thought, it's because of GDI rendering and the number of map objects and units, but earlier, there was already missions, with similar sized maps and number of units and everything worked fine then.

All in all, i can't finish this mission and proceed to the next one, so i really need help. Thanks in advance.

 

Regards,

T800

tibsun_render-warn.jpg

tibsun_files.txt except.txt

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Since nobody anwered to this request as of now, i thought, i may share some more details, config files and the problematic savefiles themselves. On my old PC a Windows XP Pro SP3 is running and the installed VGA driver is ForceWare 307.83 (the latest, as far, as i know). Other OpenGL based games are working well (for example RtCW), but - as it can be seen on the picture - TS keeps using GDI rendering, even though, ddraw.ini's "Renderer" key is configured explicitly to "opengl". I already tried the most recent and older versions of ts-ddraw and cnc-ddraw too, without any luck. Not to mention the weird behaviour, that the rendering time on a VM is significantly lower, than on the real machine. I wonder, if someone could load the attached savefiles more quickly, than my PC can?

tibsun-render-details.jpg

configs.rar saves.rar

Link to comment
Share on other sites

 Share

×
×
  • Create New...