Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
coolblue

C&C95 Crashing

Question

I'm running TFD C&C95 1.06b r1 in Windows 7.  I had no problems with the game until I got to mission 8 for the GDI.  If I send any unit down into the bottom-left hand corner and then go up in behind the house's to collect a money crate the game freezes.  I looked and I get the error:

 

"The instruction at 004b4002 referenced memory at 00000000

The memory could not be read from

 

Click on OK to terminate the application"

 

Funny thing is I downloaded the map pack from here http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/ and if I load the map from it (Mission 8 EA) the game doesn't crash!  I've tried looking everywhere for fixes but other than the compatibility mode and running in 256 colours, both of which did nothing, most other fixes apply to xp only.

 

Edit:

 

I was reading this post here http://www.cnc-comm.com/community/index.php?topic=481.0 and thought I should try that as well but I have no options to change the acceleration of sound or video infact I have no options at all!

 

Edit 2:

 

Never mind, I don't know what happened but now it just freezes all the time.  I'm going to try the other mission 8 and see what happens.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Have you tried running it in Windows 98/ME compatibility mode? And don't run it in 256 colours it will just make the game load slower and not even mentioning that C&C95 forces the entire system to 256 colours when it starts.

 

And have you tried running the game as administrator? (Left click and click on Run as Administrator).

 

Edit:

Since you are using Windows 7 have you tried running it in "XP mode"?

Share this post


Link to post
Share on other sites
  • 0

I've tried all of that and I can't run XP mode because my CPU does not support virtualization. :-(  Well, hopefully my DDR3 ram comes in today so that I can put in my new M4A78T-E, PII X2 550BE!  Then I can run XP mode.  Damn backorders!

 

So far the other mission 8 (protect mobius) has no problems and the trigger for the crash has changed again! :-(  Now it happens any time my cursor touches the left side of the screen/map.  (Once it's fully scrolled over)  Or when I try to save?!

Share this post


Link to post
Share on other sites
  • 0

Weird, but since you get an error and you posted the "error code", Nyerguds maybe able to fix this in 1.06c. :)

Share this post


Link to post
Share on other sites
  • 0

Heh? decrease the sond acceleration is for the persion who ONLY get a freeze WIHOUT error menssage or error on the video trailers (the westwood logo, ex) you are saying, when you PICK UP a crate the games crash or you go NEAR the create and the games crashes or you go into the tree and the games crashes? have a waypoint right here.

i think i have fonded the error on the map, but when i open with CCWMAP, it crashes, so, i need to open with XCC Editor, but, when i save the map someting happens! Translating: The instruction on "0x004032f5" made referency on the memory in "0x00000002" The memory cannoct be "read" Click on...

DAMN XCC! AND IT CORRUPT THE MAP!!!!!!!!

error_xcc.PNG.a2a18b7932240033c21b439c5a41c267.PNG

Share this post


Link to post
Share on other sites
  • 0

XCC editor is unreliable when it comes to triggers. I only use it for bare map editing. Never for maps with triggers. Once I start trigger stuff, I stop using XCC, or I keep a separate copy of the bare map to choose the waypoint locations

 

Also, don't derail this guy's thread.

 

 

004b4002 seems to be in completely unknown territory (I identify this code as I go), but I can trace it back to some radar-related stuff.

 

I've actually had something like this happening on my brother's PC too, where it crashed when some tree on the map was somehow currupted during the saving of the savegame, and when loading that savegame it was somehow replaced by a different terrain object that should only exist in Desert theater. On the play field it just appeared as invisible but impasssable object, but whenever the minimap wanted to show it, it crashed, because the minimap actually scales down the visible object to get a colour to put on the minimap.

Sadly, I didn't keep the address of that crash... might've been useful -_-

 

This seems to be the opposite problem though. My savegame packs have it right,m but if you just start the mission, something is wrong. Did you have a comm center at that point?

Share this post


Link to post
Share on other sites
  • 0

Well, as I've said in my latest play through I can now drive into that corner and pick up the crate but it always ends up freezing... eventually.  Yes there is a comm center but you can't build anything in this mission.  Repair whats left of the base and try to take out nod with what you have plus whatever troops you train.  The other mission 8 seems to play with no problem but if this error happens once I'm sure it'll happen again.

 

If I try loading the save game that froze upon saving all I see is a black screen, no sidebar, no mini-map but the music does start to play.  I've also have graphical errors(from before the freezing error) in all videos, the main menu and most maps.  It's mainly just pixels that are the wrong colours and doesn't affect game play but it's an error so I thought I'd share it.

 

My first attempted screen shot only shows this.

 

Well, I've been playing the map for a while and just haven't gone into that side of the map with a unit and no crashes so far.  Although eventually I'll have to take out that base over there. :-(

Share this post


Link to post
Share on other sites
  • 0

Well, the screenshot problem is common.

 

Download Arsclip from this website it is a nifty little tool that allows you to preview what you have copied to the clipboard and it corrects the screenshot error.

Share this post


Link to post
Share on other sites
  • 0

Thanks for that tool!  :D

 

Here's a screen of the game frozen:th_gamefrozen.png

 

This is the corner in question:th_badcorner.png

 

I do not have to collect the crate for the game to freeze.

 

I'm going to test something out but I believe the game only freezes with two triggers; you go into that corner and subsequently save the game.  Just a hypothesis right now, I'll let you know in a bit.

 

th_graphicalerrors.png

Here you can see the graphical errors I was talking about.  They're also in the in-game shoots, just not as noticeable.  The videos look pretty bad too.

 

After a few tests it does seem to be that corner and saving that triggers the crash.  Can anyone confirm that?

Share this post


Link to post
Share on other sites
  • 0

The colour bug is usually fixed by alt tabbing the game and going back in a few times.

 

Make sure your DirectX and Video drivers are up to date too.

Share this post


Link to post
Share on other sites
  • 0

I've narrowed it down a bit more and finally finished the mission too! :D

 

th_trigger.png

 

Just don't go in behind the trees marked in the shot and you won't trigger the crash.  Although I know if I do go up there and then save, the game will crash.  I'm not sure if your safe if you don't save after going up there.

 

No luck with the colour bug though, I have all the latest drivers and the alt tabbing didn't do anything.

 

Replayed the mission again but this time I sold my comm center... no crash!

Share this post


Link to post
Share on other sites
  • 0

try going back to your desk top a few times with the game running untill its fixed, thats what i do with Red Alert and what i use to do with CnC before the last patch fixed it for me

Share this post


Link to post
Share on other sites
  • 0

odd, there's no triggers of any kind there...

 

http://nyerguds.arsaneus-design.com/cncstuff/mappics/campaign-gdi/scg08ea.png

 

Can you give me an unresized unedited screenshot of that area if you've sold your comm center?

 

[edit]

 

Just tried the mission on my PC... no problems.

 

I know about the colour peoblem though. That's when Windows somehow overwrites the first and last 8 colours of C&C's 256-colour palette by its own standard 16-colour palette. Not sure what causes it... might be related to DirectX or graphics drivers.

Share this post


Link to post
Share on other sites
  • 0

I deleted a waypoint who, if you kill the soldiers on entrace of he village, the civilians "produce" 3 other civilians. maybe that waypoint is crashing your c&c. i deleted it MANUALY because the fu... xcc is destroying the map when i save it.

just unzip it on the c&c diretory and load the game and restart the mission to read the map.

and... only trick, when you build up a comm center on the hight resolution, press the "MAP" button on sidebar, because the radar show it a 640x400 resolution, so, rarely, and unfortunately it can crash the game.

Share this post


Link to post
Share on other sites
  • 0

I deleted a waypoint who, if you kill the soldiers on entrace of he village, the civilians "produce" 3 other civilians. maybe that waypoint is crashing your c&c.

Waypoints can't do that. Only triggers. The civvies aren't produced, but a team is created with these units in it. It's NOT the same.

 

What caused that crash is probably a foreign object slipping in there that can't be displayed on radar. You can test that by seeing if there are any invisible impassable objects there, by moving your Move cursor around the spot until you see an open spot where you get a no Move cursor.

 

 

Oh, and Revo, the xcc map fix doesn't repair maps that got damaged, it's just a conversion fix between the way XCC saves open terrain on maps and the way the original C&C maps have it saved. Older map editors have trouble with the XCC way, that's all. (the original maps use one general code for all open terrain. XCC actually saves all different cells of the "open terrain" 4x5 template)

Share this post


Link to post
Share on other sites
  • 0

I am also experiencing this problem on this map.  I just discovered 1.06 this weekend and have been playing it.  This very same mission, very same bug, is happening for me.  (I've been playing through since the start of the game, completing a mission and going to the next.  I have saved/reloaded and I've had no problems up to this point -- the bottom left corner of the map, if I explore there, crashes the game.)

 

I've attempted aborting/restarting the mission, not using my save game other than to load that level, and the problem's still occurring.

 

Error at 000b4002 I get -- a different address (but not really?)

 

I've tried your suggestion of exploring there without the radar and it works, but it crashes as soon as I later repair my power plants to get radar.  Sometimes it doesn't crash immediately when radar comes up, but it always does if I have radar and save with that corner area revealed.  I have also tried loading from your save games and the same problem happens.

 

Correction:  It does always crash if I have radar and VIEW that part of the screen.  If I've explored it, but never scroll over to it in the main screen, it won't crash.

Share this post


Link to post
Share on other sites
  • 0

umm... must be 004b4002. The internal addressing in C&C only starts at 00410000 The second value in the error message isn't that important.

 

I've got some more info on this problem now, and I'm looking into fixing it. At this moment I know

 

-The "blueprint" object of tree type T13 is corrupted, meaning all trees of that type on the map are corrupted

-It is corrupted in such a way the game thinks it is some rock of a type that only exists in desert theater

-The actual crash happens when the game tries to resize the graphics of that tree for the minimap preview. It crashes because the graphics don't exist for that theater.

-Since the terrain object's ID number is corrupted, the change is saved in savegames (because all objects are saved by their internal ID numbers)

 

 

At this moment I do not know what actually causes the corruption though.

 

I DO know what fixes it though: simply restart the game, load the mission and then restart the mission.

 

The savegame may have these trees saved incorrectly as rocks already, but it doesn't carry over the actual corruption of the 'blueprint' object, so right after starting the game, this blueprint should still be fine. And when you restart the mission, it should show the correct trees again.

 

 

Share this post


Link to post
Share on other sites
  • 0

Surely a simple fix would be to dupe the tree into the theater with the ID of the missing part?

Share this post


Link to post
Share on other sites
  • 0

You can't duplicate an object and give it the same ID. An ID is simply the index at which the game reads the object from the array of different types. the ID IS the object type.

 

And the object that's shown already exists. It's a rock. A rock that simply doesn't have graphics for the Temperate/Winter/Snow theaters. The only thing close to the fix you suggest is just adding tree graphics to the rock for temperate/winter/snow theater. That would indeed work, but that'd still be a workaround, and not a fix. The tree will suddenly become an invincible tree called "Rock".

 

It's ridiculous to go around fixing symptoms instead of finding out why the problem occurs in the first place.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×