Jump to content

Yuri's Revenge - keep menus in correct aspect ratio?


TaxOwlbear
 Share

Recommended Posts

I agree with Nyerguds on this one. Resolutions, especially native ones are underestimated by many.

 

To be honest, I don't quite get why people use awkward non-native resolutions on their flat screens, whereas every single of them claims that they know what a native resolution is. Oh well... Idiots are everywhere (no offence to TaxOwlbear, though [his name reminds me of Tamoxifen]).

 

 

Link to comment
Share on other sites

Well, the easiest solution is to give the game a resolution that makes it exactly fill the monitor, instead of a 4:3 one...

That is what I'm doing: The game fills my entire screen because I'm running it in 1920x1080. But what I would like to have is is the battlefield being displayed in 16:9 but the menus being displayed in 4:3. RA2 Vanilla does that, so I figured there could be a way to run YR like that too.

Link to comment
Share on other sites

You can only set the menu resolution in RA2. In YR it's hardcoded to run the menu and loadscreens at 800x600.

Iirc People have looked into disabling this hardcoded function and restoring it to the way it was in RA2 many times but no one has been successful at it.

 

This stretching you are talking about is solely done by the GPU driver, you need to disable it in the GPU Control Panel.

Afik you can't control this from a application it's always controlled by the driver.

Link to comment
Share on other sites

This stretching you are talking about is solely done by the GPU driver, you need to disable it in the GPU Control Panel.

Could be done by the monitor, too.

 

Just open your ra2(md).ini and set these values:

 

[Video]
ScreenWidth=XXXX
ScreenHeight=YYYY

Wallah.

 

It won't change the menus but it sure as hell will change the game (quite literally).

 

Link to comment
Share on other sites

Currently, YR stretches all menus to whatever aspect ratio your monitor has (16:9 in my case). Is there a way to keep the 4:3 aspect ratio and display the menus with black bars at the sides instead?

 

That happens because your monitor is probably connected via VGA cable hence it recieves analog signal, wich most todays monitors stretch from 4:3 to 16:9 for resolutions below 1280x960. to prevent that you have to connect it through DVI or HDMI, that should solve the problem. if you use external monitor with a notebook, then you have to set it to duplicate laptop's main screen. if it still happens with digital signal, then the problem is 95% in misconfigured driver

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...