Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
TaxOwlbear

Forced windowed mode?

Recommended Posts

That causes a generic app crash. I played around with the .ini file a little bit. Maybe it's one of the settings? Here are the default settings:

 

[ddraw]
; width and height of the window, defaults to the size game requests

width=0
height=0
; bits per pixel, possible values: 16, 24 and 32, 0 = auto
bpp=0
windowed=true
; show window borders in windowed mode
border=true
; use letter- or windowboxing to make a best fit (GDI only!)
boxing=false
; real rendering rate, -1 = screen rate, 0 = unlimited, n = cap
maxfps=0
; vertical synchronization, enable if you get tearing (OpenGL only)
vsync=false
; scaling filter, nearest = sharp, linear = smooth (OpenGL only)
filter=nearest
; automatic mouse sensitivity scaling
adjmouse=false
; manual sensitivity scaling, 0 = disabled, 0.5 = half, 1.0 = normal
sensitivity=0.0
; enable C&C/RA mouse hack
mhack=true
; enable C&C video resize hack, auto = auto-detect game, true = forced, false = disabled (OpenGL only)
vhack=false
; switch between OpenGL (opengl) and software (gdi) renderers, latter supports less features but might be faster depending on the GPU
renderer=gdi
; force CPU0 affinity, avoids crashes with RA, *might* have a performance impact
singlecpu=true

 

I changed every setting, but noting seems to make a difference, and I don't want to try all permutations. Any advice?

Share this post


Link to post
Share on other sites

are you trying to launch Sole.exe with a compatibility mode? If so disable it and try again.

Share this post


Link to post
Share on other sites

are you trying to launch Sole.exe with a compatibility mode? If so disable it and try again.

 

That was it! Thanks.

 

The game runs fine now (practice mode only, of course), with two exceptions: The map scroll speed is very fast, even on the lowest settings, and the menu windows are transparent for some reason (i.e. there is no background and you can see the map or other menus underneath).

Share this post


Link to post
Share on other sites

are you trying to launch Sole.exe with a compatibility mode? If so disable it and try again.

 

That was it! Thanks.

 

The game runs fine now (practice mode only, of course), with two exceptions: The map scroll speed is very fast, even on the lowest settings, and the menu windows are transparent for some reason (i.e. there is no background and you can see the map or other menus underneath).

 

Try and set maxfps to 300 in ddraw.ini and HardwareFills to 0 in conquer.ini.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...